deploy failure with %>% as package


I have a {golem} shiny app that gives me the error:

peparing to deploy application...DONE
Uploading bundle for application: 2595126...DONE
Deploying bundle: 3414935 for application: 2595126 ...
Waiting for task: 764509862
  building: Parsing manifest
  building: Building image: 3822923
  building: Fetching packages
  building: Installing packages
  building: Installing files
  building: Pushing image: 3822923
  deploying: Starting instances
  rollforward: Activating new instances
  terminating: Stopping old instances
Application successfully deployed to
Deployment completed:

But then I get this in the log.

Error in value[[3L]](cond) : could not find function "%>%"
Calls: local ... tryCatch -> tryCatchList -> tryCatchOne -> <Anonymous>
Execution halted

The application runs locally in a fresh R session and I've ran usethis::use_pipe() so I know I'm including the pipe in my package! [I'm uploading the entire package to the server]

To make matters weirder my co-worker tried deploying the app and it worked?!?

Anyone know how I could even trouble shoot this??? I'm at a loss and creating a reprex of a tiny golem app with a %>% has just resulted in applications that work :woman_facepalming:

Any insights/help appreciated!!

can you list the library or require statements that appear in your app?

Since the app is structured as a package I can show you my NAMESPACE file? note the FIRST export!! I also opened the manifest.json to ensure the %>% is exported!!

# Generated by roxygen2: do not edit by hand


In fact since I've now tried everything I not only export it using usethis::use_pipe() but also import it twice?!

Is this the right file? Happy to keep sending any other information I'm totally at a loss....

I've tried uninstalling the application and removing my local cache and starting over I'm wondering if the server has some cached info I can't seem to shake?