Shiny server stopped serving apps, just shows `Not Found`

My install was working fine for many months and yesterday it stopped working. Won't server app.R files or even index.html. The files are clearly there, but the shiny server acts like it cannot find them.

I have checked all the log files and I can't find anything amiss. The files are all location in /srv/shiny-server/apps. The shiny server runs as user shiny. The permissions for /srv/shiny-server is set as follows:

drwxr-xr-x 22 roger shiny-apps    4096 Apr  7 03:08 .
drwxrwsr-x 15 roger shiny-apps    4096 Apr  7 11:33 ..
drwxr-xr-x  3 roger shiny-apps    4096 Mar  5 12:50 activity_metrics_definitions
drwxr-xr-x  2 roger shiny-apps    4096 Mar  5 02:09 chaininfo_charts
drwxr-xr-x  3 roger shiny-apps    4096 Jan 19 19:47 contracts_NOT_USED

roger and shiny are both members of the shiny-apps group.

If I check the shiny-server log file for the app I tried to reach, this is the only output:

su: ignoring --preserve-environment, it's mutually exclusive with --login

Listening on

Execution halted

Furthermore, I have tried all the suggestions in this post: Shiny server gives "Page not found" selectively to a specific parent directory - #4 by andresrcs

Anyone have any ideas on where to start debugging? Thanks in advance.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.