Shiny server only allows one instance running

I am hosting a shiny server on Ubuntu 16.04, and am using Ngnix for authentication. The server worked fine until recently it only stopped allowing multiple user use it at the same time. When a new user logs in, both the new user and the user currently using it will be kicked out, and whoever refresh the web page first will get in, and both users will be kicked out again once another person tries to get in. The screen will just grey out and "Disconnected from server" will show up in the bottom left corner.

There is no error in the log, the following will show up in the browser console. I haven't made any changes to the code in a long time, the only changes I made recently was updating R from 3.3 to 3.4 and R studio to the latest version last week. I also installed the latest version of shiny server after encountering this problem.


Any help will be much appreciated!


Wow, that's really strange. Does it happen with even a simple Shiny app? Is there nothing in either /var/log/shiny-server.log or /var/log/shiny-server/*.log?

No error in the logs. I updated all the packages and now I cannot even access shiny server... It says "ERROR: An error has occurred. Check your logs or contact the app author for clarification." and in the browser console it says GET http://xxxxxx/favicon.ico 500 (Internal Server Error).

I removed the favicon.ico and code for favicon from ui.R and it still gives me this error...

Man I really feel like a shiny newbie today... After using it for almost two years

EDIT: after changing the "run as" user from shiny to my own user, the favicon error disappeared and I have no idea why...

1 Like

I also removed all the database connections from my app, still no luck. There is no error in the log, only messages for loading packages.

I tried a simple app and I can run multiple instance at the same time, so there must be something wrong with my code... But I didn't make any changes to my code for nearly a month

I moved all the code and data files for my shiny server to another server, and it works just fine with multiple users using it at the same time

EDIT: just checked the most recent logs, and found "8066 Segmentation fault (core dumped) R --no-save --slave -f /opt/shiny-server/R/SockJSAdapter.R" at the bottom of the log file