Shiny server error downloadable font: download failed

Hi everyone!
I recently setup a new server after we had to take down the old machine and I'm now trying to activate an app again that was running perfectly a year ago. The app is working fine if I run it from RStudio but immediately disconnects when I try to access it from the server although the app is displayed correctly as far as I can see).

No log files are created so I'm guessing that the R script is running fine and just terminating without an error. The Java console is giving me an 404 error for a font (awesome-font) that it isn't able to download. I only included awesome-font icons for a small menu and the icon are displayed there correctly. The error persists even if I use glyphicon for the icons or remove the icons altogether.

The app is available at and the error message was as follows:

This page uses the non standard property “zoom”. Consider using calc() in the relevant property values, or using “transform” along with “transform-origin: 0 0”. miREV

GET [HTTP/1.1 404 Not Found 0ms]

GET [HTTP/1.1 404 Not Found 2ms]

downloadable font: download failed (font-family: "FontAwesome" style:normal weight:400 stretch:100 src index:0): status=2147746065 source:

GET [HTTP/1.1 404 Not Found 2ms]

downloadable font: download failed (font-family: "FontAwesome" style:normal weight:400 stretch:100 src index:1): status=2147746065 source:

Wed Nov 16 2022 17:19:22 GMT+0100 (Central European Standard Time) [INF]: Connection opened. shiny-server-client.min.js:1:21816

Wed Nov 16 2022 17:19:22 GMT+0100 (Central European Standard Time) [DBG]: Open channel 0 shiny-server-client.min.js:1:5375

The application unexpectedly exited.

I'm guessing it could be a compatibility error between a fresh shiny server installation and an older app script but I cannot figure out what the problem is unfortunately. If anyone can give me a hint or point me to a solution, I would be very grateful.
Kind regards,

Hi Benedikt!

Indeed, I have tried accessing your app and it crashes after loading.

When you say that "no log files are created", have you checked the /var/log/shiny-server/ directory in your shiny server (which is where logs live by default)? Are there any files there related to your app?
If so, those may give more detailed information about the nature of the error.

Aside from that, some off-the-top-of-my-head guesses are that this issue is due to some package version conflict, defunct functions, missing dependencies, or even some data issues (if, for instance, you are connecting to a remote DB).

But before jumping into any of those, let's see if we can get ahold of those logs :sweat_smile:
Also, if the app code is public, this could help find possible points of failure (as those I pointed out above).


This post was published by an Appsilon team member. Our company can help you get the most out of RShiny and Posit/RStudio products.

Check our open positions here.

Appsilon: Building impactful RShiny Dashboards and providing R coding services.

This topic was automatically closed 54 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.