Shell does NOT open in RStudio Server With Tensorflow-GPU for AWS (

I logged in to the server (version and tried to use the shell to change the user password as instructed. Nothing opens. Duh?

Do you mind providing a bit more detail about what you are trying to accomplish? It sounds like you are trying to run the RStudio Server AMI here:

Is that accurate? And then what directions are you following to change the user password? Also, what are you looking to open? Are you trying to access RStudio Server in the browser and not finding it?

Are you familiar with setting up servers in AWS and the types of networking rules you need to set up for browser-based access?

EDIT: I have successfully found the instructions you mention (with help!). But your clarification on the other questions would still be helpful! Where in this process are you stuck?


I am wiping everything out and starting over from scratch. I'll document what I do and let you know if failure occurs. Thx.


Whereas my previous problem was that I could not access the shell within the RStudio instance provided via the Marketplace, I now find that (after closing out everything) and resubscribing to the Marketplace, I cannot access the server via EC2 Management Console or via the Marketplace.

I tried using: (1) a webpage with IP-address:8787 and (2) putty (with same IP-address. Not even a prompt.

Help appreciated. BTW, I have successfully used AWS via the EC2 Management Console before.

Are you using the Public URL / IP address? Have you checked out the networking rules you are attaching to the instance to be sure that the ports you are trying to connect to are accessible?

You do see the server running / up in your list of EC2 instances, correct?

I have a similar problem, I just wrote a post about it (but it's pending).
I finally figured out how to ssh to the server, but no idea how to actually start the Rstudio server. Pasting the public DNS in the browser times out

A couple of things you will probably want to check:

  • the output of netstat -lntp will tell you what services are listening on which ports
  • the output of something to the effect of sudo rstudio-server status will tell you if the service is up. More specifics and options at
  • If the public DNS in the browser times out, you will probably want to look at the "Security Group" or other networking associated with your instance. If the port is not open to traffic from your IP address, then you will run into that type of timeout behavior. (You are being blocked by a firewall)

Thank you for responding @cole. I was able to run those top two commands you suggested and they seemed to indicate that everything was running properly. Another poster provided the solution - explicitly opening another port 8787.

1 Like