shared object ‘’ not found


When trying to load packages (all that I have tried, this is an example), I get this message:

Error: package or namespace load failed for ‘Rcpp’ in library.dynam(lib, package, package.lib):
shared object ‘’ not found

If I attempt to install a package it seems as if it aborts:

install.packages("vegan", dependencies = TRUE)
Installing package into ‘/Users/manniv/Library/R/3.6/library’
(as ‘lib’ is unspecified)
trying URL ''
Content type 'application/x-gzip' length 3643550 bytes (3.5 MB)

downloaded 3.5 MB

The downloaded binary packages are in

Don't know what to do!

Thanks, Viola

The installation of vegan seems successful (there is no error message; yes it's a bit disturbing but totally normal that there is no success message either).

For Rcpp, library() can only work if the installation was previously successful. Did you run install.packages("Rcpp") and did it work? If not, what is the error message?

I'm not very familiar with MacOS (if anyone else wants to chime in...), my understanding is that you may need to install the c++ toolchain yourself. There are detailed instructions here, see in particular his package to do it automatically.

Hi Alexis, Thank you for responding. I am having some real issues with R, and because I don't really understand how Rstudio is interacting with Rscript, I don't know how to describe my issues.

Problem 1: I set up a conda environment to work with a suite of programs. During a test of the suite it told me I needed to update some R packages. I ran an update and it did not update within the conda environment but in my base directory. This is when things started to go bad. Libraries wouldn't load and RStudio kept crashing.

Problem 2: Because RStudio kept crashing I re-loaded the program and the latest version of R. Now, Rstudio is running R version 4.1.2. But here's another tricky thing. When I look at my R libraries, there are only two directories, one for 3.5 and one for 3.6. Where is 4.1? UGH! I wish I understood theses things better.

I think I have gotten some good help on how to handle updating within my environment, but I would surely like to understand how R is interacting with RStudio and R libraries. Any help there would be great!

Thanks! Viola

I'm afraid as soon as conda is involved, I have absolutely no idea either, I never managed to get R working through it.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.