Set NO_PROXY variable for rstudio package manager

Hey guys,

I've some big troubles with the rstudio package manager. I've installed everything and it's running quite smoothly. I set up two repository: one cran mirror repo that needs to access the internet and one repo containing packages from our internal gitlab server.

Here is the problem. In order to let my RSPM server access the internet, it has to go through our company proxy. Therefore, I added

URL = proxy.address:port

inside the rspm config file. Now the manager can crawl packages from CRAN. However, our policy requires that for internal address (like our internal gitlab server), the communication should bypass the proxy. That is why the NO_PROXY environment variable of the underlying ubuntu system is accordingly set so that the server should communicate with all internal servers without the proxy. However, the package manager somehow ignores this setting and tries to connect to the proxy when using a git-builder. This functionality only works when commenting out the proxy setting in the configuration of the package manager. But as you probably guessed, this leads to the fact that no cran packages can be crawled from the internet anymore.

Any ideas on how to solve this?

I would recommend setting the proxy environment variables in the systemd configuration file instead of the Package Manager config file. For example:


You should be able to add this to /etc/systemd/system/rstudio-pm.service.d/user.conf.

After making changes, you need to reload the systemd configuration and restart Package Manager:

sudo systemctl daemon-reload
sudo systemctl restart rstudio-pm
1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.