Sessions was terminated - message

Since I've updated RStudio I'm having a little issue with the software. I'm just pointing out this, because I'm using a preview version of the software and my hope is that if this is a bug you may correct it. Anyway thank you for your time and great software.

After turning on the PC, the first time I open RStudio I'm getting this error:

And I cannot make any operation: "1 + 1" doesn't return any results.

I have to close RStudio and reopen it so I can work (second time everything works).

About RStudio days:

Version 1.1.364 – © 2009-2017 RStudio, Inc.
Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/538.1 (KHTML, like Gecko) rstudio Safari/538.1 Qt/5.4.1


R version 3.4.1 (2017-06-30)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows >= 8 x64 (build 9200)

Matrix products: default

[1] LC_COLLATE=Spanish_Peru.1252
[2] LC_CTYPE=Spanish_Peru.1252
[3] LC_MONETARY=Spanish_Peru.1252
[5] LC_TIME=Spanish_Peru.1252

attached base packages:
[1] stats graphics grDevices utils datasets
[6] methods base

loaded via a namespace (and not attached):
[1] compiler_3.4.1 tools_3.4.1 yaml_2.1.14


Hello, your last R session probably used files that were moved or renamed. So every time you open rstudio it can not find these files so the session is terminated. You have to reset user state.

One option is never save your last session by changing your global settings and uncheck every option forces rstudio to call your last session (e.g. "Restore previously opened project at startup")

But i thik that these answers from rstudio support there are more appropriate:
To reset user state:

if you want to chek if there is also other problem:


I am having similar issues. However, mine rarely crashes on opening. It starts fine and may execute some code but eventually gives the same error message as above. I then typically have to Ctrl+Alt+Del my way out and restart (but no guarantee it won't happen again the next time.)


Any chance you can make your project public so we can try and reproduce the issue on our end?

Unfortunately these issues are often very hard to diagnose -- all we know is that R is crashing during startup, and there's a lot of reasons why this could occur (corrupt R workspace, a broken R installation, a broken R package installation, some kind of RStudio issue being triggered when attempting to restore open files / other session state...) To make matters worse, we typically don't see anything particular helpful in the log files either. :-/

You might try sharing the project you're working with, alongside your RStudio Desktop folder (the folders discussed at to see if an IDE engineer can reproduce the startup crash you're seeing.

1 Like

For me, the problem didn't seem isolated to a specific project (and cleared up as soon as I rolled back to the standard release.) Unfortunately, any of the projects I encountered this problem with were for work and could not be shared. When I get a chance, I'll try to reinstall the preview version and create some sort of a "reprex project" (reproj? reprojex?). Thanks!


@emilyriederer @kevinushey That looks like the same issue that I've reported and a few other people have said they are also experiencing in this thread and on the RStudio support site:

Yes, sure. To which email should I send the files?

You can send them to Thanks!

@kevinushey, sent the files.

Another issue, not sure if related, is this one:


My situation: I also have "random" crashes on RStudio startups. When it occurs, the situation is quite similar to yours. I've tried things like "Resetting a user's state on RStudio Desktop", however, I couldn't completely solve or reproduce the problem.

My recent finding: I found that RStudio is likely to crash after I update the preview versions, because I usually go with the portable version for Windows. Each time I unzipped the latest version in a different directory, then the Windows Firewall tries to block the R session executable file.


I think the firewall settings have something to do with the crashes, so please check the firewall setting after update, and especially try the new Terminal tab after successful startups. If the "Windows Security Alert" pops out, click Allow access, and I think this would increase the chance of sucessful startups in future.

Hope this helps.

@o_gonzales @emilyriederer We've released a new preview this morning, 1.1.379, which contains a fix for this issue. Would you be willing to try it out and let us know if it resolves your problem?

1 Like

Willing? "Stoked" is more like it!

I'll try it out a few days and report back. Thanks for the heads up!

1 Like

@jonathan @emilyriederer same here. Already testing.

I'll report back in a few days.


@jonathan -- Smooth sailing so far! Happy to report no more crashes.

The only thing I still notice is that the preview version seems takes perceptibly longer to boot and switch between projects than the official release, but this is just a first impression and not based on hard evidence. Could just be my impatience to start playing with some of the new features.