Security update 2021-007 for MacOs Catalina causes RStudio to crash

After the 2021-007 security update to Catalina 10.15.7 on my Macbook Pro, RStudio refuses to start. Other apps are also affected. Google Earth Pro, Stellarium at least. The common factor might be something to do with Qt.

When I first noticed this a few days ago, there was nothing on the internet. But now reports are starting to occur. Not heard RStudio mentioned yet. Hence this post.

1 Like

A friend told me a way to solve this problem. It worked perfectly. Do this steps:
0) Uninstall R and RStudio and download R and RStudio packages

  1. Reboot your Mac in safe mode
  2. Reinstall R and RStudio
    3)Lauch RStudio and in RStudio Menu bar go to 'Preferences'
  3. Options - General: Advanced folder - OS Integration Rendering engine (choose 'Software') and Apply and close R
  4. Boot normal

I hope it helps you. Best regards

1 Like

Update: I tried DandaraBR's solution, but I didn't reinstall R or RStudio. I just changed the Rendering Engine to Software. And it worked!

This happened to me too. I haven't found a solution yet.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.