runApp() Error in ..stacktraceon..({ : No arguments!

In my current project I have the weird problem, that I cannot run shiny-apps in the ws/project directory anymore. Whether its ui/server or just the default app (as created by new) it gives me:

Error in ..stacktraceon..({ : No arguments!

If I run from a subfolder I don't have any problem but I cant do that as I need the renv environment and I have to run it on a shiny server which doesn't look in the subdirectories for shiny apps.

I am using the latest renv 12.5 # RStudio, tried with shiny 1.5 and 1.6 and R 3.8 and 4.0. Additionally I put the app on my shiny server which has different setup and it gives exactly the same error:

Error in ..stacktraceon..({ : No arguments!
Calls: runApp ... force -> lapply -> FUN -> eval -> eval -> ..stacktraceon..
Execution halted

Is someone having an idea? This error is really hard to debug/figure out. I thought it might be related to renv as this is the only consistent factor on my local machine and the server.

This topic was automatically closed 54 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.