RStudio won't start


I have used RStudio without issue for years, today I started receiving errors regarding some packages, and from this evening RStudio will not open at all. R Gui works fine.

When attempting to open RStudio, I receive the greyed out IDE screen with the progress wheel in the centre, and all menu items are greyed out. After a minute or so, I receive the error:
"Initializing RStudio. The RStudio server is taking a long time to respond. It is possible that your R session has become unresponsive. Do you want to terminate the currently running R session?"

So far I have tried uninstalling and reinstallinr R, RTools and RStudio, as per:

This has not resolved the issue.

Earlier today when running scripts that had previously worked fine, I suddenly was unable to load ggplot2 or tidyverse, and started receiving an error message like "...there is no package called 'Rcpp'". I did not save the error message, and now cannot recreate it (as RStudio will not open).

The R version that I have installed is 3.6.1. The RStudio version is RStudio Desktop 1.2.5019.

OS is Windows 10 Pro. Version 1709, Build 16299.1087.

I am a freelancer and the majority of my work is via RStudio, so I urgently need a working setup. I am happy using R, but have not faced an issue like this before and do not know what to try next. Any help would be very much appreciated.

Searching for similar issues, one suggestion is to see what is specified in my PATH. I am not sure if this is of any help but:

[1] "C:\Rtools\bin;C:\ProgramData\DockerDesktop\version-bin;C:\Program Files\Docker\Docker\Resources\bin;C:\Program Files (x86)\Common Files\Oracle\Java\javapath;C:\Program Files\Tcl\bin;C:\Program Files (x86)\Intel\iCLS Client\;C:\Program Files\Intel\iCLS Client\;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\Common Files\Adobe\AGL;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files\Intel\WiFi\bin\;C:\Program Files\Common Files\Intel\WirelessCommon\;C:\Program Files\Git\cmd;C:\Program Files (x86)\gnupg\bin;C:\WINDOWS\System32\OpenSSH\;C:\Program Files\TortoiseSVN\bin;C:\Users\ucesmac\AppData\Local\Microsoft\WindowsApps;C:\Program Files\Intel\WiFi\bin\;C:\Program Files\Common Files\Intel\WirelessCommon\;;C:\Users\ucesmac\AppData\Local\Programs\Microsoft VS Code\bin"

Two main places to start:

Worst case scenario, you might try uninstalling and reinstalling R + all required R packages.

Thanks kevinushey. I went down the route of uninstalling R, RStudio and all packages. RStudio seems to be running ok now. I do not know what the problem was, but thankyou for the suggestions.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.