RStudio Won't Open on Mac Catalina

RStudio has recently starting failing to open on my Mac running Catelina 10.15.2. I've tried the terminal commands mentioned in the other solutions on this board, and tried changing my version of R, all to no avail.

Interestingly, some older versions of RStudio do still run, namely 1.4.1743 and older.

The error message is too long to post here, but here's the header of error message I get when RStudio fails to open. I can post other specific parts of it if useful, but I'm not savvy enough to know which parts are important:

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       EXC_I386_GPFLT
Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Segmentation fault: 11
Termination Reason:    Namespace SIGNAL, Code 0xb
Terminating Process:   exc handler [719]
1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.