RStudio won't lauch on Windows 10

I recently updated to the latest version of RStudio Desktop (1.4.something), and the program will no longer launch on my computer. As in, when I try to open it, the computer thinks for a minute then does nothing that I can see.

I have tried:

  • uninstalling and re-installing RStudio
  • Updating the System PATH to ensure that R and RStudio are on it
  • Removing startup files
  • Resetting the state
  • Uninstalling the latest version an re-installing version 1.13.1093

There is nothing in the log file, no crash report, no error messages. Tried running a diagnostic report at it also does nothing.

R opens and runs fine. I have been able to use RStudio with no problem on this computer for years. Several security updates were installed on Windows a few days before I tried to upgrade RStudio, but the active installation worked fine after the updates.

I am at a loss, and will be grateful for any suggestions!

Windows specs:

Edition Windows 10 Enterprise
Version 20H2
Installed on ‎4/‎7/‎2021
OS build 19042.1237
Experience Windows Feature Experience Pack 120.2212.3530.0

Device specs:
|Processor|Intel(R) Core(TM) i7-7700 CPU @ 3.60GHz 3.60 GHz|
|Installed RAM|32.0 GB (31.9 GB usable)|
|Device ID|104473E3-E9E5-4E5C-A134-AF9F91447070|
|Product ID|00329-00000-00003-AA448|
|System type|64-bit operating system, x64-based processor|
|Pen and touch|No pen or touch input is available for this display|

1 Like

I have been trying to get help on this for a while, with no avail. I can open RStudio, but all I see is the command bar on top, and a blank screen. I have found absolutely no help on his. I have been wondering if this is a way of, in fact, phasing out the free version of RStudio desktop. I am subscribed to RStudio Cloud, and that one works perfectly

Hi Jorge & Nicole,
Unfortunately I have the same issue. The only thing I've been able to do as a temporary work around is to uninstall and reinstall the old version 1.1.463
That version works on my Dell laptop, but any of the more recent versions simply don't start up. I've tried doing a clean boot and still get the issue so presume it is not a conflict with some other software but a problem with Windows since a recent update. Hoping someone can help or provide some advice.

Hi Jorge & Peter,

The IT department at my university was able to fix the problem - it was an issue with a Windows security update. That said, I did not even remotely understand what they did to fix it, so I can't offer much advice!

Thanks Nicole. I guess that's a tiny bit of a clue but doesn't yet get me much closer to a solution. I wish I knew what steps your IT department took to look into it.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.