RStudio Window Blank - no solutions from similar posts


RStudio window is blank when I start it. Menus do nothing.

I have read through the other posts describing this problem and none of their solutions seem to help with mine.

I am using Windows 10.
I have previously installed Microsoft R Open 3.5.1, which works on its own with no problems.
I have downloaded and installed RStudio 1.2.1335 from the RStudio website. No problems during the install.
When I start RStudio the main window opens up with menus but everything else is blank and the menus do nothing.
I normally use a non-elevated user.
I had to install by providing admin user password (so that RStudio could install into Program Files I guess).
If I hold CTRL as I start RStudio I am presented with a dialog that clearly has found the MRO installation.
I know that company computer policies prevent the execution of applications from non-system locations: Program Files is ok, user's AppData would not be ok. But I can't see RStudio violating this policy.
Similar policies also prevent use of CMD.exe, which some applications try to use without showing the user.
I can successfully execute RStudio "As Administrator", but this is not allowed by company policy and I don't think it should be required.
I have found the logs stored in ".....\AppData\Local\RStudio-Desktop\log". rsession log is empty and rdesktop.log contains this:

17 Jun 2019 12:21:25 [rdesktop] ERROR Main window closed unexpectedly; LOGGED FROM: auto __cdecl rstudio::desktop::MainWindow::closeEvent::<lambda_4cc4d0df19b92db780de6d80571f943a>::operator ()(class QVariant) const c:\jenkins\workspace\ide\windows-v1.2\src\cpp\desktop\desktopmainwindow.cpp:281

(note that c path is not mine)

So has anyone in this community experienced something similar or have any troubleshooting instructions?



I tried running as admin because I write my own company policy - so no similar policy. It didn't fix my similar problem. If you launch R, can you access the window? The only way I know it's running is task manager or hovering over the icon on the task bar. If you have any movement with this, I'd love to hear about it.


I can launch Microsoft R Open and I get the user interface for that. The R session works fine in there.

Holding CTRL as I start RStudio enables me to choose the R environment, so I guess RStudio is able to see and use the MRO?

My home PC, using the same tool versions, doesn't have these issues.


Thanks bphilpot,

I tried Microsoft R Open and got as far as the window to select which distro to use. Then had no change. I appreciate your help.


This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.