RStudio will not start; libicuuc issue

Hi there, ubuntu 20.04, RStudio 1.3-1093. R-4.0-3 installed and works fine from the commandline.

But Rstudio gives:

/usr/lib/rstudio/bin/rsession: error while loading shared libraries: cannot open shared object file: No such file or directory

I have tried very hard to install this libicuuc thing without success. can anyone advise?

Have you tried installing Ubuntu's libicu package?

$ sudo apt install libicu60

Hello jonathan, thanks for this. This is what happened:

hankin@cuttlefish:~ $ sudo apt install libicu60
[sudo] password for rhankin: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libicu60
rhankin@cuttlefish:~ $ 

any advice?

On Ubuntu 20.04, rsession links to the following ICU libraries:

$ ldd rsession | grep icu => /lib/x86_64-linux-gnu/ (0x00007f916053c000) => /lib/x86_64-linux-gnu/ (0x00007f916023d000) => /lib/x86_64-linux-gnu/ (0x00007f915e5d2000)

which are normally provided by:

sudo apt install libicu-dev

Can you confirm that you downloaded the binary of RStudio built for Ubuntu 20.04, and not an older version of Ubuntu?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.