Rstudio unworkable on Windows 10 Pro


I recently bought a new PC with Windows 10, and to my dismay Rstudio has become a nightmare to work with. Within 10-20 minutes of activity, it becomes slow to respond to any type of activity within the script or console. Typing, scrolling, clicking the menu, clicking objects in the environment, browsing the console etc. The slowness gets worse over time, that is, when I first start Rstudio it works fine for 10-20 minutes and then gradually deteriorates until it becomes unworkable. The problem isn't limited to a particular project or script.

I tried every suggestion I could find online to sort this out but to no avail. This includes: changing compatibility mode (to windows 8), adding Rstudio as an 'exclusion' on my antivirus, pausing/disabling windows updates and all the 'basics' of clearing the console, zoom on "100%", disabling diagnostics, restarting R. Also, this is a new PC, i.e., it is practically 'empty' with nothing in particular to take up space or eat up memory as I'm working.

Some technical details:
RStudio version: 2021.09.0-351.exe
R version: 4.1.1
Windows 10 Pro
Processor intel i7, x64 bit

I'm at my wits end at this point, any thoughts or ideas on how to fix this?

Hi and welcome!

Did you try unchecking 'include version control within RStudio' from the global options, git-tab? It did solve my problems with RStudio and Win 10 Pro.

Hoping it does same for you,


Thank you for the welcome.
I just tried it per your suggestion (and restarted R), unfortunately there is no change.

To bad it didn't work out for you the way it did for me. I am afraid I have to pass offering other solutions. Good luck


Have you tried changing to software rendering?, you can change it by holding the Ctrl key while opening RStudio, then you should see this menu and change the "Rendering Engine" to "Software".

1 Like

I did try this before. I honestly don't know why nothing is working for me.
I think there must be something running in the background that needs disabling, and since this is a new PC, I believe it has to do with windows 10. I just cannot figure out what is slowing Rstudio like this. My previous PC ran on Windows 8 and everything was working great, never encountered any problems. This is very frustrating as I bought a better PC to handle large datasets, only to not be able to actually work on it.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.