RStudio Unresponsive

RStudio opens with several blank windows on my laptop and it becomes unresponsive after some time. This happened after I linked a Github repository with RStudio. I have done everything suggested in previous posts within this RStudio community. My issue is as it is. Any help will be highly appreciated.

Thank you

do you have a project with an associated GitHub repo? Is the repo huge? Possible it has lots of really big text files in it?

No, my repo was a small file (with two lines of text). I deleted that repo with the hope that RStudio might start behaving. However, it is still showing multiple blank windows. I reinstalled both R and RStudio twice (yesterday and today), but no luck. It is still showing the same issue. Any guidance will be appreciated. Thank you.

can you share your version of R:

just type:


and also your version info from RStudio?

you can get that from the Help menu in RStudio then click about

I am using the most up-to-date R version. It is 3.6.3 (64 bit).

I think, it may be helpful: My RStudio does not let me click on any of the menu options.

which operating system, which version of RStudio?

I am using Windows (10) based Dell XPS laptop. RStudio is 1.2.4052.

I am having exactly the same issue as MPant, and have downloaded the same versions of R and RStudio. As soon as I tried to connect to Github, RStudio started opening multiple panes and wouldn't stop. Since then, I cannot get it to work (same issue every time). Re-installing R, Git and RStudio hasn't helped. Any help would be appreciated! Thanks

Hello Htisc,
I was able to fix this issue by deleting the local directory created during the procedure of linking github repository from my computer. I also deleted the github repository from my github account. Then, I uninstalled and reinstalled current versions of R and RStudio. When I restarted the RStudio, it worked without an issue. I hope, this may help you.

Hello jdlong,
Thank you for taking interest in the issue I was facing. As written in the reply to Htisc, I was able to resolve my issue.
Thank you for your time and attention.

Hi MPant,

I really appreciate you responding! I have deleted the github repository and am about to re-install R and RStudio, but how did you delete the local directory created during the linking of the repository to the computer (sorry, I am a newbie!)? I assume you are also on the Productivity Tools part of the Data Science course, so did it work when you went back and reconnected with the homework-0 repository on github?

Thanks again, I am not able to move forward without your input so I am very happy for your help.


Hi MPant, Many thanks for this! How do I find the local directory you mentioned though? Regards, Htisc

i have a Same issue and that fix by your solution: deleting the local directory.
دانلود مداحی

Hi bita, what exactly did you delete? AppData/Local/RStudio-Desktop? Or just one of the files in there (which one)? Many thanks in advance!

Hi Htisc:
I first went to Global Options from within RStudio's Tools menu to see the local directories on my computer. Then, I went to those local directories from File Explorer to delete them. Please see the picture of Global Options from within Getting Started section of the web site
I hope this helps.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.