RStudio unresponsive to R version change

Hello everyone,

I encountered a problem when trying to change the R version in RStudio on my Windows 10 Enterprise (64-bit) laptop. The PC has R 3.6.1, R 4.1.0 and R 4.2.2 installed, with R 3.6.1 being recognised as the default and which it successfully starts up. I tried to change the version through “Tools > Global Options > Change” but the pop up does not show up (GUI unresponsive). Alternatively, using “ctrl” during the startup prompts an “R Not Installed” error. I wiped everything and reinstalled all versions of R and RStudio and the issue remained. Similar issues in the past were associated with the "desktop.ini.lock" file located at C:\Users\myaccount\AppData\Roaming\RStudio which currently contains:








Deleting "desktop.ini.lock" prompts the “R Not Installed” error but I found a workaround by changing RBinDir to “RBinDir=C:/PROGRA~4/folder/R/R-41~1.0/bin/x64”. This allows Rstudio to start with R 4.1.0. However, just adding the RBinDir for R 4.1.0 as a new line will result in loading the default R 3.6.1

I don’t understand this behavior and would be grateful for advice on how to fix this. Thank you!

Change window being unresponsive is a bit weird. Other than that you can just reset rstudio all together for the initial version select panel to show up again but there is no guarantee that it will be responsive. Follow these steps If everything else fails just delete rstudio and install again.

Thank you for the response. I have tried reinstalling it before without success and doing the reset, according to the link you provided, unfortunately does not solve the problem either. After the reset, R Studio does not find R anymore.
This is such weird behavior particularly since the pop-up is the only part that appears to be unresponsive.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.