Rstudio unable to see ODBC drivers

I used to have the connections working fine but things updated and now I cannot connect to a networked SQL Server. I am able to connect using MS Azure but Rstudio will not connect. I have the drivers installed. In my odbcinst.ini I see the driver listed

[ODBC Driver 17 for SQL Server]
Description=Microsoft ODBC Driver 17 for SQL Server

however when I run odbc::odbcListDrivers() I get

[1] name      attribute value    
<0 rows> (or 0-length row.names)

In a terminal window when I run odbcinst -j. it displays the drivers in /usr/local/etc/odbcinst.ini

I tried updating Renviron to include ODBCSYSINI=/etc and also tried ODBCSYSINI=/opt/homebrew/etc based on Solutions - Setting up ODBC Drivers to no avail. All steps I tried restarting my computer.

What else am I overlooking or how can I fix this? Thanks.

I figured out something that fixed it, although not entirely sure why it works.

sudo ln -s /usr/local/etc/odbcinst.ini /etc/odbcinst.ini
sudo ln -s /usr/local/etc/odbc.ini /etc/odbc.ini

In terminal, based on Install the Microsoft ODBC driver for SQL Server (macOS) - ODBC Driver for SQL Server | Microsoft Learn

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.