Rstudio tries to download packages that don't exist (I think)

System is Windows 10 x64, using R v4.0.5 and Rstudio v1.4.1106. Recently clean installed Windows. Tried reinstalling R and Rstudio multiple times after too.

I'm trying to use packages like tidyverse and shiny. Shiny has dependencies of httpuv and later, so when I went to install them I get the error "Cannot open URL 'https:// ...": HTTP status was '404 Not Found'", also shown below. I went into the repository on a browser and saw that the package indeed doesn't exist. I've tried many repositories (as listed in Tools -> global options -> packages) other than the but they also don't have the packages "" or "" that rstudio is attempting to download.

Am I doing something wrong here, like working with an incompatible version of R (v4.0.5)? Why is rstudio trying to download packages that don't exist? My temporary workaround is separately downloading the packages I need on and installing them as tar.gz, but hopefully there's a simpler solution to all this. Thanks in advance

This seems like a connectivity issue, R is not being able to connect to the CRAN repository you have selected, these are some things to try.

  • Choose a different CRAN repository, RStudios repository is a good choice ( or you could choose one that is geographically closer to you.
  • Disable secure download setting.
  • Check if your internet connection has traffic restrictions of some kind, like a firewall, proxy server, etc. This is usually the case when you are at work or school.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.