RStudio/tidyr::separate Crashing Windows 10

RSTudio/tidyr Crashing Windows 10

I'm reshaping some data using RStudio 1.2.5019 (and R 3.6.0) on a Windows 10 computer, using mostly tidyr. I'm running into a very strange issue that I can't seem to find anywhere. I had originally used separate() three times to split three columns into 12 columns each, connected by pipes, and it took a little time but it worked just fine. I realized I didn't need one of the separates, so I took that one out, and that's when I ran into this issue (which persists when I try to run it with just one separate too).

When I try to run this section of code, I've had a couple of different results:

  1. RStudio appears to crash, and any open tabs in Chrome also close spontaneously. I receive this error: "The application was unable to start correctly (0xc00012d). RStudio appears to stay open, but is just a blank white screen with the menu bar.
  2. RStudio appears to crash, both of my screens go to black (laptop and monitor) and then return to normal. No error message, and RStudio uses 99% of my memory for about a minute even though it appears closed.
  3. RStudio appear to crash, both of my screens go to black. No error message, and I can move my mouse but the computer is otherwise non-responsive and I have to force reboot using the power button.
  4. RStudio crashed and displays the "RStudio encountered a fatal error" message. Existing Chrome tabs that were already loaded/not actively retrieving content change to the "something went wrong" page.

What I've tried so far:

  • Clearing the environment and re-running the code

  • Restarting RStudio

  • Restarting my laptop

  • Reinstalling tidyr

  • Deleting RStudio-Desktop from AppData > Local and RStudio from AppData > Roaming

  • Reinstalling RStudio

I'm totally stumped - the data set isn't big enough for it to be a RAM issue (<1k rows, 30 cols max), and there aren't really any specific error messages to go off of. Any ideas as to what is happening here? Thanks in advance!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.