RStudio This site can't be reached refused to connect

I am currently on Mac OS Catalina

I have previously installed R 3.6.x and RStudio and everything was functional (this was on Mac OS Mojave). I just updated to Catalina. For a project I am currently working on, I am using a tool that was developed using R 3.4.0. As a result I attempted to download and install R 3.4.0 following these instructions.

The download and installation appeared to be successful, however when I attempt to open the .Rproj, RStudio opens and reports "This site can't be reached refused to connect."

I reinstalled RStudio and attempted to follow instructions online to reset RStudio's state, however the issue persists.

Do I need to download an older version of RStudio? Is this issue occurring because I updated my OS? Any advice on how to proceed?

Hi @apilsons,
Welcome to the RStudio Community Forum.

I'd take a step back for a moment .... what "tool" are you referring to? Is it a package that was built under R-3.4.0? Are you sure its not available for R-3.6.3 (on CRAN, Github, bioconductor, etc.)? It may still install and work in R-3.6.3; have you tested it?

If the "tool" is a script file it is likely to run OK, or could be modified so that it can run.
Can you give us more information?


The tool I am referencing is the Open Language Chief Executive Personality Tool. More information can be found at the dropbox link I cite at the bottom.

I have tried using R-3.6.3 when running the script, however there are compatibility issues with certain packages in the scoring script. As a result I have been attempting to run RStudio with R-3.4.0, the version that the code was developed with. When I open RStudio, however, the site can't be reached.

If anyone has any information regarding why this is occurring, it would be greatly appreciated.

There is not a version of this tool for more recent versions of R.](

OK, so I see why trying to run OLCEPT on R-3.6.3 will be a problem (e.g. the {multidplyr} package is not on CRAN, not even in the Archives).

If both R-3.4.0 and R-3.6.3 are successfully installed on your Mac machine, maybe the problem is that RStudio is starting in the "wrong" R version. It defaults to using the latest version. You can get a list of installed versions to select from when starting RStudio by holding down the key. Once RStudio has started in the correct version, then open the project file to continue as before.


I have a new update. After uninstalling R and RStudio and retrying the entire process, I discovered that RStudio would open correctly without refusing to connect up until creating a symlink to R with the following commands.

sudo ln -s /opt/R/{R_VERSION}/bin/R /usr/local/bin/R
sudo ln -s /opt/R/{R_VERSION}/bin/Rscript /usr/local/bin/Rscript

These commands were found here ( which I also linked above. These commands occur after I have verified the installation of R-3.4.0. However because a file already existed when I ran the first command, I changed the command to sudo ln -sf ... to force the symlink.

I can currently run R-3.4.0 from the command line using by typing 'R', however RStudio will still not open correctly. Does anyone know what is causing RStudio to fail to open correctly or how to fix this issue?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.