RStudio stopped working on Pixelbook Linux (Beta)

I have been using RStudio on my Google Pixel book with Linux (Crostini NOT Crouton) for almost a year now and it has been great. However, RStudio suddenly stopped working and I only a get spinning wheel over the RStudio icon in the toolbar - it never arrives at opening a blank RStudio window. I suspect it may have been related to the most recent update of Chrome OS (Version 76.0.3809.136 (Official Build) (64-bit); released Aug. 30, 2019 but may have been pushed to my machine sometime in September). So far, I have tried power washing my Pixelbook and reinstalling Linux, R, RStudio several times, including current and previous versions of RStudio:

  • 1.2.1335
  • 1.2.5001

I have tried installing using the Pixelbook Linux right-click approach as well as with sudo gdebi -n r-studio.deb where r-studio.deb is one of the above versions. I have also used the instructions on this page for Linux users ( without success. In all cases, RStudio installs without an error. Any help would be appreciated.

If you haven't already, you can try resetting RStudio's state: (since RStudio maintains some state outside of the regular install location)

Thanks for the reply. Based on the link you provided, RStudio should create the rstudio-desktop folder the first time it starts. I can't find any instances of this folder within the Chromebook's Linux directory or outside, such as in the Chrome OS location usr/lib/rstudio, where some RStudio files are stored outside of the install location. So, it seems that it's never reaching the point in the startup that it can make that folder. Does that make sense?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.