RStudio Starting and Connecting to R, but nothing shows in the GUI

I am having an issue where I can upgrade packages, but I cannot open a project, create a project, or make a new script of R, Python, or SQL, and probably the other file types too though I have not tried them. I have tried all of the following:

  1. Check the version of R: I have the most recent version of R, which is R 3.6.3 64bit version
  2. I have checked to see if starting with a different file location by holding the crtl button and tried all of the options available. None of the options made any difference and when I tried to browse to a different location that might work, I was unable to add this location to the list of possible options.
  3. I was unable to try removing the files .Rprofile, .Renviron, and .Rdata because I am unable to determine where my working directory is, sorry about this. I did see them in different directories, but none of the directories that I saw them in were in a location that looked like the working directory. I also assume that they would all be in the working directory instead of spread out if I was actually in the working directory.
  4. I ran Sys.which(“R”) in my R GUI and it returned that is was using R 3.6.3, which is the most current version of R I have installed and is the version I want to be used.
  5. I checked the firewall, proxy settings, and antimalware, at least I think I did. I show no policies limiting R’s access to any ports because there are no policies involving R, and there are no connection policy rules. I also looked at the diagnostic report and it says that the connection to R is made, so I do not think this is the issue. Also R is able to connect to CRAN as it appears to be able to download packages.
  6. I was unable to navigate to navigate to the location of ~/.rstudio-desktop directory so I was unable to check the read and write permissions
  7. Reset RStudio’s state, when doing this I renamed the files .rstudio-desktop to backup-rstudio-desktop-3 and the file RStudio to backup-rstudio-3 as I have tried this possible solution many times. This did not work.
    a. Here is the output from backup-rstudio-3:
    i. [mainwindow]geometry=@ByteArray(\x1\xd9\xd0\xcb\0\x3\0\0\0\0\0\b\0\0\0\x1e\0\0\x4\xb7\0\0\x3y\0\0\0\b\0\0\0\x1e\0\0\x4\xb7\0\0\x3y\0\0\0\0\0\0\0\0\x5\xa0\0\0\0\b\0\0\0\x1e\0\0\x4\xb7\0\0\x3y)
    b. Please let me know if you need the contents of backup-rstudio-desktop-3
  8. Now I am trying solution 8, which is to open a new topic in Here is the needed information
    a. The diagnostic report: I have uploaded to GIST at the following link:
    b. General description: I start RStudio it appears to be connecting to R, but the GUI does not show any details thus if files are opening or there is a working directory than I cannot see them loading. There is no output to the GUI, except for the top tool bar.
    c. The output of RStudio.Version():> RStudio.Version() output--Error in RStudio.Version() : could not find function "RStudio.Version"
    d. No error messages are displaying on the screen.
    e. Log files rdesktop and rsession-Maureen were blank
    f. Crash reports: There were no instructions on how to run this report on windows
    g. Attempted steps taken to fix: see above
    h. Success before: Over a year ago with a different version of R and RStudio

Thank you for your time!

Diagnostics included

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.