RStudio shows blank white screen on startup when git is installed

I have a student in my class running a Windows 11 laptop with the latest versions of RStudio and R installed and working as expected.

Whenever we install git (Using either gitbash or chocolatey, the two options for Windows users described in and relaunch RStudio, RStudio only shows a blank white screen. If we uninstall git, the problem goes away.

The blank screen behavior is similar to other reported issues (e.g. Problem with RStudio showing white screen on startup - #5 by andresrcs), but in this case the user name has no spaces or non-ascii characters, the problem does not occur when git is not installed, and the rolling back to R 4.1.3 does not fix this problem.

Any ideas of how to debug?

What happens if you simply download the installer from the official website? I have never had any problem with that method.

Thanks, but installing git from Git - Downloading Package is precisely the "Option 1" listed in for windows which is the first approach we tried. As noted, this doesn't work.

I'm sorry I do not have more information about this student's specific setup. I am very aware that installation method you describe often works on Windows machines; my classroom has 54 students, about half of them use windows, and for all but this one student we were successfully able to set up RStudio with git as I've done every other year for the past 7 years. I realize this issue is probably rare and may be difficult to reproduce and thus to debug, but figured I should report what I know.

Maybe this is specific to Windows 11? (this is the first year I'm seeing Windows 11 appearing in the classroom). Maybe something else? Please let me know what additional information might be helpful to start debugging this properly, or other things we might try.

Thanks everyone for the help!

Just to rule out common troubleshooting tasks, have you tried resetting RStudio's state after installing Git?

No, that's a good idea. We'll try renaming the %appdata%\RStudio directory (I assume that's still the path on Windows 11) and see if it makes any difference.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.