RStudio session crashes on running nloptr

I am trying to run a non-linear constrained optimisation using the nloptr package. When I run the optimisation the Rstudio session crashes. The log files don't seem to capture this crash. The last log file is from some weeks back. The diagnostics report also shows this as the last error:

31 Jul 2021 12:49:50 [rsession-dhruvakaggarwal] ERROR system error 2 (No such file or directory) [path=/Volumes/GoogleDrive/.shortcut-targets-by-id/1uELoLTtQ0-MVlZj5loA1k2gZAdJlDODV/SEA-LBL/Dhruvak]; OCCURRED AT: rstudio::core::Error rstudio::core::FilePath::makeCurrentPath(bool) const /Users/rstudio/rstudio/src/cpp/core/FilePath.cpp:1037; LOGGED FROM: virtual void rstudio::session::modules::rmarkdown::notebook::ChunkExecContext::connect() /Users/rstudio/rstudio/src/cpp/session/modules/rmarkdown/NotebookExec.cpp:202

When I request logs it shows this:

Screenshot 2021-08-19 at 17.12.44

The session does not crash when the optimisation problem is run on a substantially smaller sample dataset, which might point to limited RAM on the system? I'm running it on an 8GB system, but I've tried it on a 32GB system and it still crashes. Curiously, it doesn't crash on another 16GB system.

Session info:

R version 4.0.0 (2020-04-24)
Platform: x86_64-apple-darwin17.0 (64-bit)
Running under: macOS  10.16

Matrix products: default
LAPACK: /Library/Frameworks/R.framework/Versions/4.0/Resources/lib/libRlapack.dylib

[1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

loaded via a namespace (and not attached):
 [1] Rcpp_1.0.7       compiler_4.0.0   pillar_1.6.2     bitops_1.0-6     tools_4.0.0      lifecycle_1.0.0  tibble_3.0.1    
 [8] gtable_0.3.0     lattice_0.20-41  pkgconfig_2.0.3  rlang_0.4.11     Matrix_1.2-18    cli_2.0.2        DBI_1.1.0       
[15] rstudioapi_0.11  binman_0.1.1     dplyr_1.0.7      generics_0.0.2   vctrs_0.3.8      askpass_1.1      mitools_2.4     
[22] caTools_1.18.0   tidyselect_1.1.0 grid_4.0.0       glue_1.4.0       R6_2.4.1         processx_3.4.2   fansi_0.4.1     
[29] XML_3.99-0.3     survival_3.1-12  RSelenium_1.7.7  purrr_0.3.4      ggplot2_3.3.0    semver_0.2.0     magrittr_1.5    
[36] ps_1.3.2         scales_1.1.0     ellipsis_0.3.2   splines_4.0.0    assertthat_0.2.1 colorspace_1.4-1 utf8_1.1.4      
[43] survey_4.0       openssl_1.4.1    munsell_0.5.0    wdman_0.2.5      crayon_1.3.4  

I am unable to figure out the cause for this. Please help.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.