Rstudio session aborts after opening it

I have installed RStudio on Mac OSX from this file: RStudio-1.1.419.dmg, found at this address: However, when I start Rstudio, by double-clicking Rstudio in Applications for example, it aborts immediately and gives the following message: 'R Session aborted, R encountered a fatal error, the session was terminated'. It gives me the option 'Start a new session' but if I click it, the fatal error happens again. I have tried deleting '.rstudio-desktop' from my home to reset the default parameters but this did not improve the situation. I had Rstudio before and I removed it but maybe there is some leftover of my previous installation interfering with this one? Anyone has got some suggestions to help me, please?

There's more people with the same problem with RStudio v1.1.419 crashing constantly.
Check other threads in this forum for more info as it would be interesting as well to have the logs showing what happens to you.

Can you provide us with a diagnostics report?

Open the diagnostics report with TextEdit. I changed the .txt extension to .jpg so that this website lets me upload the file. The situation has somewhat improved in that Rstudio now lets me run one command before crashing.

A link to the diagnostics report:

I am not sure I uploaded it successfully to

The only thing that stands out from your diagnostics report is the fact that you're using Homebrew R rather than CRAN R (the error logs are otherwise empty).

In my limited experience, I've occasionally seen crashes due to mixing binary packages installed from CRAN with Homebrew R, but I cannot be certain if that's what's causing the crash in your case.

You might try setting up a file at ~/.Rprofile or ~/.Renviron to adjust the library paths based on whether you're using Homebrew vs. CRAN R, in case that's affecting you.

@kevinushey How can I do this 'You might try setting up a file at ~/.Rprofile or ~/.Renviron to adjust the library paths based on whether you’re using Homebrew vs. CRAN R, in case that’s affecting you.'? Indeed, I have been mixing homebrew and CRAN. I have tried to start from scratch by uninstalling RStudio from homebrew and reinstalling it from CRAN manually but I keep having the same problem.

Here's the code I have in my .Rprofile:

  # Don't use a user library if we have a site library on OS X
  # (ie, don't die when we're using homebrew R)
  isHomebrew <-
    identical([["sysname"]], "Darwin") &&

  if (isHomebrew) {
    Sys.setenv(R_LIBS_USER =

Probably not the best solution, but it worked back when I was testing out Homebrew R.

Unfortunately, this did not work. It's also weird. I seem to remember that I already had a .Rprofile (where I specified where to look for packages for example) but I had to create it because I did not have one already. I pasted what you wrote in there but R keeps crashing. The crash is a bit different though. It's a pop-up window, it does not give the option to restart, there is also a window just saying 'null'.

Are you able to successfully run R from the terminal?

yes, I am able to run R in the terminal. It does not crash. I have run complex scripts from the terminal successfully.

Well actually, I am getting this error when I want to load dplyr in the terminal, which I did not use to get:


 *** caught segfault ***
address 0x18, cause 'memory not mapped'

 1: dyn.load(file, DLLpath = DLLpath, ...)
 2: library.dynam(lib, package, package.lib)
 3: loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]])
 4: namespaceImport(ns, loadNamespace(i, c(lib.loc, .libPaths()),     versionCheck = vI[[i]]), from = package)
 5: loadNamespace(package, lib.loc)
 6: doTryCatch(return(expr), name, parentenv, handler)
 7: tryCatchOne(expr, names, parentenv, handlers[[1L]])
 8: tryCatchList(expr, classes, parentenv, handlers)
 9: tryCatch({    attr(package, "LibPath") <- which.lib.loc    ns <- loadNamespace(package, lib.loc)    env <- attachNamespace(ns, pos = pos, deps)}, error = function(e) {    P <- if (!is.null(cc <- conditionCall(e)))         paste(" in", deparse(cc)[1L])    else ""    msg <- gettextf("package or namespace load failed for %s%s:\n %s",         sQuote(package), P, conditionMessage(e))    if (logical.return)         message(paste("Error:", msg), domain = NA)    else stop(msg, call. = FALSE, domain = NA)})
10: library(dplyr)

Possible actions:
1: abort (with core dump, if enabled)
2: normal R exit
3: exit R without saving workspace
4: exit R saving workspace

That likely implies you need to reinstall dplyr and/or its dependencies. Try something like:

deps <- tools::package_dependencies("dplyr")$dplyr

dplyr problem solved. Unfortunately, the Rstudio crashes again with the following message:

R encounterered a fatal error

The session was terminated. Ok

If I try to run a chunk, a window with 'null' appears.