Rstudio server problem

Hi, I'd like to ask some questions about Rstudio server on GCP.

I am trying to open Rstudio server(not pro, but open source) by using GCP,

but it doesn't work well.

here are the lists of my problems.

  1. my computer OS is linux centos 8. First I created my VM, and I was able to install R and Rstudio server with using some codes in my VM. And then, I could not access to Rstudio server even though I wrote my ID and PW properly. I thought it might be a firewall issue, so I tried to set firewall with code as below.

sudo gcloud compute firewall-rules create allow-rstudio --allow=tcp:8787

However, it didn't work at all and error came out like this.

Required 'compute.firewalls.create' permission for 'projects/amazing-insight-271301/global/firewalls/allow-rstudio'

I'd like to know what it means and how to solve this problem.

  1. Mark Edmonson stated how to launch Rstudio server in the google cloud with two lines of R. I tried to follow the instructions, but I couldn't install googlecomputeengineR package in Rstudio server. I want to sort out this problem.

  2. finally, I'd like to know whether it is possible to operate Rstudio free server at my google cloud VM.

Hope I could get some useful advice on those problems mentioned above.


This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.