RStudio Server Pro on RHEL8 with SELinux

We've an installation of RStudio pro on a RHEL 8 VM. Policy requires SELinux to be enabled. We can temporarily disable SELinux (setenforce 0), but as soon as SELinux is enabled we get a 502 Bad Gateway.
How can we configure RStudio and/or RHEL so RStudio can be accessed with SELinux enabled?

This is not an answer, but some of the advice at SELinux errors with RStudio Server and RStudio Server does not work with SELinux might be relevant.

In addition, you can try:

  1. Turn on SELinux in permissive mode, which will disable SELinux but log all failures/warnings
  2. Use the logged failures/warnings to set the appropriate SELinux contexts where needed (RStudio product binaries or other relevant paths). This includes sudo chcon for setting SELinux attributes/contexts or ls -Z for checking SELinux attributes
  3. This is not 100% foolproof, since it will just test the basic product functionality, but some later action could trigger something that was not whitelisted. A good reason to leave SELinux in permissive mode in case another issue comes up in the future, and you can repeat Step 2.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.