Rstudio server not connecting on wsl2 windows 11


I am currently having problems using an Rstudio server instance on WSL2 on Windows 11.

I had been using it for a couple of years and everything worked fine until last week it spontaenously stopped working. At this point I could log in to the instance and it seems to work initially but after a few seconds it gives me an unable to establish connection error and I'm not able to input code or interact with Rstudio at all. Trying to log back in after this gives me a connection error.

I have tried multiple reinstalls, including completely removing R and reinstalling, as well as playing around with firewall settings in Windows in case this was issue, to no avail. In addition I have also tried changing the port but this also makes no difference.

As far as I can tell, there is no useful information in the rserver log file either.

Does anyone have any experience with this issue and know how to resolve this?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.