RStudio Server keeps disconnecting

I am experiencing extreme connection issues and I do not know what to do. I'm running RStudio server with version 1.1.383. The server is running on an ubuntu 14.04 desktop. I often work on that desktop and just work with RStudio server to maintain project continuity between my remote work and on-site work.

I experience no connectivity issues when I am working directly on the desktop.

However, when I am working remotely from my Windows 10 i7 laptop via the Chrome, my RStudio sessions frequently lose connection. Specifically, I get the following error:

Error: Unable to establish connection with R session

Typically, everything will be running fine. Then the console response time starts lagging (e.g. 4 seconds for 1+1). Then I'll get that error. Sometimes, after a few seconds everything starts running smoothly, sometimes not.

I know it sounds like I'm losing my internet connection, but I don't think that's actually the issue. I'm now sitting next to my router and when I lose my server connection, my internet connection appears stable and fine.

I have tried:

  1. Clearing the console
  2. Clearing my workspace
  3. Restarting and stopping/starting RStudio Server sessions
  4. Restarting my session
  5. Terminating and starting a new session

Typically, these will temporarily restore my connection, but then the issue starts again.

This has actually become a huge problem and has dramatically decreased my productivity. I'm kind of at my wits end and would really like some help.

Had exactly the same issue and it was related to the data.table package. Did you recently update any packages, or do you have the data.table package installed?

Can you provide us with a diagnostics report? It sounds like your R session may be crashing -- hopefully there are some hints as to what might be happening in there.

I updated RStudio to V1.2.1335 this week and have been repeatedly getting the "Error: Unable to establish connection with R session" message regardless of whether I work on a project connected to GitHub or just presented on my local drive.

I have reinstalled RStudio and updated all packages and the issue still persists. The error pops up more frequently when I tried to work on projects in GitHub with problems committing. BUt I get the error message even on local projects. I am using wired connection.

Attached are screenshot of the message I get:


The diagnostic report after a fresh installation of Rstudio is here: