RStudio Server is taking longer to start than usual

Hi All,

I see the error " R is taking longer to start than usual" when I try to login RStudio IDE. on RHEL 8 machine.


Could anyone please guide me how to fix this error.

Thank you.

Hi All,

I tried with all the above three options. But, No luck.

Can anyone please suggest some pointers as it is critical to run RStudio?

Thank you in advance.

Hi All,

Only one user is experiencing this problem. Other users can able login fine.

When I check the -- rstudio-server status, I see below error for that user login

Nov 03 11:00:12 RHEL8 rsession-trin[2230931]:
ERROR session hadabend; LOGGED FROM: rstudio::core::Error {anonymous}::rInit(const rstudio::r::session::RInitInfo&) src/cpp/session/SessionMain.cpp:675

Machine Details:
OS: Red Hat Enterprise Linux 8.3 (Ootpa)
Kernel: Linux 4.18.0-240.1.1.el8_3.x86_64

R version : R 4.1.0
RStudio Server: 1.4.1717 (Juliet Rose) for CentOS 8

Can anyone please suggest me how to fix this error.

Thank you in advance.

If only one user is affected, the issue is with that user's settings. This can include

  • Issues in .Rprofile
  • Large and corrupted .RData files left over from a previous session
  • Broken/hung existing session
  • General issue in the .rstudio folder in the user's home

I would ask the user to

  1. Start R on the command line outside of R studio (to see if there is issues with .Rprofile or .RData or any R specific setup)
  2. If the user wants to reconnect to an existing session, maybe kill that session as it could be hung/busy/stuck.
  3. Temporarily move .rstudio out of the way (move it to .rstudio.bak) and get the user to try again.

Hi Micahelmayer,

Thank you for your reply.

I deleted the "rstudio" folders from users home directory like..



Along with "rstudio" folder, I also deleted, a folder named "R" from user's home directory "/home/trin".

This worked for me. But, this issue is happening again and again with same user.

Please let me know that Is there any permanent fix for this problem.

Thank you once again.

Hi Shiva,

If it is really one user impacted and all the other's are fine you probably need to figure out what this user is doing.

A few more pointers:
Is he/she using large workspace data that brings his session down ? (you should see large .RData files hanging around in his folders)
Do you have any disk quota on the home directories that the user may exceed and hence cannot run any session ?

Hi Michaelmayer,

Thank you for reply.

Correct. I will check with the user whether he is running any large data sets.

Thank you once again for the pointer.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.