RStudio Server for Ubuntu 22.04 LTS fails to start

In Ubuntu 22.04 LTS, I have the following error that I cannot solve (this is from the journalctl -u rstudio-server logs:

rstudio-server[111428]: Failed to start rstudio-server.service: Interactive authentication required.
rstudio-server[111428]: See system logs and 'systemctl status rstudio-server.service' for details.
systemd[1]: rstudio-server.service: Control process exited, code=exited, status=1/FAILURE
systemd[1]: rstudio-server.service: Failed with result 'exit-code'.

I'm using 2023.03.0-386 (latest stable) although I tried the daily build and got the same result.

It seems to be an authentication error, but it occurs when I install RStudio or try to restart it, using a sudo command from an admin account. I've confirmed that R (v4.3.0) runs fine from the command line.

Any insight would be appreciated!

Solved it! It turns out I had two service files existing simultanously and they were clashing:

I disabled the /etc file and it started working. Hope this helps anyone else who hits this!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.