Rstudio server for Debian 11

I am trying to install Rstudio server onto a VM running Debian 11 hosted on Google Cloud: PRETTY_NAME="Debian GNU/Linux 11 (bullseye)" I am getting an error that file is not found. I have read up here that this error is caused by installing the wrong version. Ok, but the page only lists two versions, Debian 10 / Ubuntu 18 / Ubuntu 20 and Ubuntu 22. I have tried both of these and I get the same error each time ( not found).

Any suggestions are welcome.

Update, I tried building rstudio server from source and when I run ./install-dependencies-debian I get a message Error: Unsupported Debian release. I am running Debian GNU / Linux 11 (bullseye), which is the latest version AFAIK. Hard for me to believe rstudio won't run on the latest version, so what I am doing wrong? Its a VM, if I were to build a new one, what version of linux should I choose? This is blocking me from further development. Thanks in advance.

The error with seems to hint that you may inadvertedly have downloaded rstudio-server for Ubuntu 22 LTS, maybe in the hope that this will work with Debian 11 ? If you use the Debian 10 binaries however, they will still install on Debian 11 and together with installing r-base seem to still work quite well (although not officially supported at the moment).

Download link I used for my tests is

If you're looking for a version of RStudio Server that is guaranteed to work, you are at the moment limited to Debian 10, Ubuntu 18.04, 20.04, 22.04 from a Debian based linux distro perspective.

Thank you Michael. Using the Debian 10 binary worked. I thought I had already tried that before, but anyways, just happy that it is working now. Thanks again for your help.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.