Rstudio server Error occurred during transmission

I am using Rstudio server 1.3 in a remote deskptop, which runs linux ubuntu 18.04.4. Last friday, it crashed and I have been unable to use since then. I can log in, but then get a message: "Error occurred during transmission". Calling journalctl gives me a very similar error message to the one shown here:

I have reinstalled rstudio server and deleted the .Rhistory, but these had no effect.

any pointers to a solution would be great.

Hi all,

For future reference, I was able to solve this by following:

I renamed my .rstudio folder to .rstudio-old. With this, I was then able to login and access everything. Will still leave the .rstudio-old for a few days and then delete it once I confirm everything is working well.


For others who face the same issue (or future me), the solution @rramiro suggested didn't work for me on Rstudio Server version 1.3.1093, but the general concept worked. Based on the link he/she kindly shared:

user files are stored in three separate locations

~/.config/rstudio/ 	            All user settings (Global Options)
~/.local/share/rstudio/ 	    All open files and tabs
~/.rstudio/ 	                All active and suspended sessions

On my computer, the ~/.rstudio had only one empty folder inside, and renaming it and restarting the rstusio daemon via systemctl restart rstudio-server.service didn't help. What worked for me was renaming the ~/.local/share/rstudio/ via:

mv ~/.local/share/rstudio ~/.local/share/rstudio.old

and the restarting the daemon:

systemctl restart rstudio-server.service

and then refreshing the browser. Just as a headsup, the rstudio took about 20 seconds to load after this (probably because it had to create all those file we practically removed).

Nevertheless, special thanks to @rramiro :beers:


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.