RStudio Server - Could not connect to the R Session on R Studio Server

Hi all,

I'm trying to get a Shiny / RStudio server set up on RHEL 9 and I'm stuck.
R - Successfully installed, v4.4.1.

RStudio - Successfully installed but errors

I've created an rstudio user, have set up the password, and have set up the /home/rstudio folder. I've confirmed the user exists via cat.

Any ideas what I've done wrong? This is all new to me but I'm comfortable with quickly picking up new things - just need to be pointed in the right direction :slight_smile:
Chris

You indicated that you installed on RHEL 9 so I will tailor my answers to that OS.
I am going to assume that you installed the open source version RStudio Server (as opposed to Posit Workbench).

First, based on the information in your screen shot I would suggest updating the hostname on your system to the correct Fully Qualified Domain Name (FQDN). You can use the hostnamectl command to view and update the hostname. Unless, of course, you are only only going to access the system in localhost mode.

Next, to correct the permission denied error you are getting you need to disable FAPOLICYD. This is the File Access Policy Daemon and is designed to keep unauthorized programs from running in places where no programs should be running. To do this, you would execute the following commands:

sudo systemctl stop fapolicyd
sudo systemctl disable fapolicyd
sudo systemctl status fapolicyd

This will stop the deamon, disable it from starting on reboot, and the last line should give you something similiar to:

● fapolicyd.service - File Access Policy Daemon
   Loaded: loaded (/usr/lib/systemd/system/fapolicyd.service; disabled; vendor preset: disabled)
   Active: inactive (dead)

Once this is done, your rstudio service should start properly.
-Ray

1 Like

Hi @raymondval - Thanks for the detailed info...but I'm still stuck. I'm not worried about the FQDN (I'm likely going to be accessing everything via Remote Desktop and using localhost) but when I try and stop fapolicyd, I get a message that the service is not loaded. This is very frustrating - the info in the docs and your reply are very simple, even for me who has no Linux experience, but I don't know what else i can do.
Chris