Rstudio-server broken after upgrade to ubuntu 18.04

Rstudio-server cannot start after upgrade the system form ubuntu 16.04 to 18.04.

sudo rstudio-server verify-installation

give error

/usr/lib/rstudio-server/bin/rserver: /usr/lib/x86_64-linux-gnu/ version `OPENSSL_1.0.2d' not found (required by /usr/lib/rstudio-server/bin/rserver)
/usr/lib/rstudio-server/bin/rserver: /usr/lib/ version `OPENSSL_1.0.2d' not found (required by /usr/lib/rstudio-server/bin/rserver)
Job for rstudio-server.service failed because the control process exited with error code.
See "systemctl status rstudio-server.service" and "journalctl -xe" for details.

re-install openssl or rstudio-server do not fix the issue.

any help?


I am facing the same issue.

What version of RStudio Server are you running? I was able to successfully install and run RStudio Server v1.1.447 (open source) on Ubuntu 18.04.

V 1.1.447 from the Rstudio website.

I'm also on Ubuntu 18.04 , which is upgraded form Ubuntu 16.04.

Ubuntu 16 and Ubuntu 18 require different versions of RStudio Server because of the libssl upgrade. Can you try installing the Ubuntu 17+ version from our website?

Just jumped on here to confirm that I'm having the same issue. I'm on a completely fresh Ubuntu 18.04 virtual machine and got the not found error. I double-checked and made sure that I had installed the rstudio-server-stretch-1.1.447-amd64.deb package for Ubuntu 17+.

Then, out of curiosity, I uninstalled the broken Ubuntu 17+ package and installed the Ubuntu 16 rstudio-server-1.1.447-amd64.deb one. This worked out-of-the-box and I now have RStudio Server running on port 8787 with no additional configuration.

To summarize: for me, the "correct" Ubuntu 17+ package didn't work, but the old Ubuntu 16 package did.


It still doesn't work. However, the same as anon_1, I install the ubuntu 16 version, and it works.

Yes, it also works for me. Thank you so much!


Definitely. Glad it wasn't just me!


Can confirm, using the 16.04 install on 18.04 was the solution for me as well.

1 Like

Both the "Debian 9+" and "Debian 8/Ubuntu" versions of the deb packages list in their dependencies libssl1.0.0 | libssl1.0.2 – based on my own experience and this thread, this is too relaxed. Could the package maintainers confirm this and possibly correct the dependencies to the level actually required?

I am using Ubuntu 16.04 LTS (fresh install); the "Debian 9+" version complained about missing, even though according to the package manifest, either that or 1.0.0 (installed) should work.