Rstudio Server appears to start without error but cannot be accessed

I have noticed Rstudio server won't start. It was working this morning; now it does not.

I am typically the only user using the software.

To solve the problem I tried to restart, stop, start

bensmith@MSMServer:/expdata/bensmith$ sudo rstudio-server restart
bensmith@MSMServer:/expdata/bensmith$ sudo rstudio-server stop
bensmith@MSMServer:/expdata/bensmith$ sudo rstudio-server start

None of the commands produce any output. When I try to connect to the browser using the browser hangs for about a minute, and then I get a timeout error in the Chrome browser.

# This site can’t be reached
****  took too long to respond.

If I run

bensmith@MSMServer:/expdata/bensmith$ sudo rstudio-server stop

then try to connect in the browser, I get the same error, but it returns immediately (<2 s) rather than actually timing out. For that reason (and because I haven't changed anything related), I don't think this is a www or proxy server misconfiguration.

I tried to clear .Rdata, .Rprofile, .Rhistory from the last used project folder, and also renamed /home/userfolder/.rstudio to /home/userfolder/.rstudio-backup, but this made no difference.

At the R console, sessionInfo() returns

> sessionInfo()
R version 3.5.1 (2018-07-02)
Platform: x86_64-pc-linux-gnu (64-bit)
Running under: Debian GNU/Linux buster/sid

Matrix products: default
BLAS: /usr/lib/x86_64-linux-gnu/atlas/
LAPACK: /usr/lib/x86_64-linux-gnu/atlas/

 [1] LC_CTYPE=en_US.UTF-8       LC_NUMERIC=C              
 [3] LC_TIME=en_US.UTF-8        LC_COLLATE=en_US.UTF-8    
 [7] LC_PAPER=en_US.UTF-8       LC_NAME=C                 
 [9] LC_ADDRESS=C               LC_TELEPHONE=C            

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

loaded via a namespace (and not attached):
[1] compiler_3.5.1

Any ideas what I should do next to get it working?

1 Like

After typing sudo rstudio-server start, you could try netstat -lntp to see if any service is listening on port 8787. You could also check out sudo rstudio-server status and cat /var/log/syslog (on Ubuntu) or cat /var/log/messages (on RHEL), I think. Hopefully one of those will give you a little bit more information to go on!

If you are able to share /etc/rstudio/rserver.conf or /etc/rstudio/rsession.conf, that might be helpful as well! I presume this is the open source version of RStudio Server?

1 Like