RStudio server 1.3.1093 compiled from source on Debian 10 fails to run on start

I have installed RStudio server from source on a Debian 10 system (ARM processor), I'm using the init file found here /usr/local/lib/rstudio-server/extras/init.d/debian/rstudio-server but the server doesn't run on startup. Running sudo rstudio-server status gives me this error:

rserver[459]: ERROR asio.netdb error 1 (Host not found (authoritative)); OCCURRED AT rstudio::core::Error rstudio::core::http found (authoritative)); OCCURRED AT rstudio::core::Error rstudio::core::http::initTcpIpAcceptor(rstudio::core::http::SocketAcceptorService<rstudio_boost::initTcpIpAcceptor(rstudio::core::http::SocketAcceptorService<rstudio_boost::asio::ip::tcp>&, const string&, const string&) src/cpp/server/ServerInit.cpp:85; LOGGED FROM: int main(int, char* const*) src/cpp/server/ServerMain.cpp:635

Running sudo rstudio-server verify-installation doesn't give me an error message

Can anybody give me a hint on what is going wrong?

If I restart rstudio-server everything works ok but the next time I restart the machine I get the same error message.

Note: I can't install from the .deb file since I'm on an ARM system, not x86.

I solved my problem by copying all the initialization scrips on usr/local/lib/rstudio-server/extras to the corresponding system locations but it still would be nice to know which one is the correct one for debian10 so I don't copy files unnecessarily.

- src: /usr/local/lib/rstudio-server/extras/init.d/debian/rstudio-server
  dest: /etc/init.d/rstudio-server
- src: /usr/local/lib/rstudio-server/extras/systemd/rstudio-server.service
  dest: /lib/systemd/system/rstudio-server.service
- src: /usr/local/lib/rstudio-server/extras/upstart/rstudio-server.conf
  dest: /etc/init/rstudio-server.conf

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.