Rstudio-server 1.1.453 &&


I saw an update on Rstudio website for Rstudio server and I tried to upgrade my Rstudio server to the more recent version through the following:

sudo apt update
sudo apt upgrade
sudo gdebi rstudio-server-stretch-1.1.453-amd64.deb

and I got:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading state information... Done

RStudio Server
RStudio is a set of integrated tools designed to help you be more productive with R. It includes a console, syntax-highlighting editor that supports direct code execution, as well as tools for plotting, history, and workspace management.
Do you want to install the software package? [y/N]:y
(Reading database ... 563695 files and directories currently installed.)
Preparing to unpack rstudio-server-stretch-1.1.453-amd64.deb ...
Unpacking rstudio-server (1.1.453) over (1.1.442) ...
Setting up rstudio-server (1.1.453) ...
useradd: user 'rstudio-server' already exists
groupadd: group 'rstudio-server' already exists
Created symlink from /etc/systemd/system/ to /etc/systemd/system/rstudio-server.service.
Job for rstudio-server.service failed because the control process exited with error code. See "systemctl status rstudio-server.service" and "journalctl -xe" for details.
● rstudio-server.service - RStudio Server
Loaded: loaded (/etc/systemd/system/rstudio-server.service; enabled; vendor preset: enabled)
Active: activating (start) since Mon 2018-05-21 13:32:06 EEST; 3ms ago
Main PID: 1862 (code=killed, signal=TERM); : 23383 (rserver)
Tasks: 7
Memory: 1.1G
CPU: 181us
CGroup: /system.slice/rstudio-server.service
└─11760 /usr/lib/rstudio-server/bin/rsession -u mehu --launcher-to...

May 21 13:32:06 HP-EliteDesk-800-G1-TWR systemd[1]: Starting RStud...
May 21 13:32:06 HP-EliteDesk-800-G1-TWR rserver[23383]: /usr/lib/r...
May 21 13:32:06 HP-EliteDesk-800-G1-TWR systemd[1]: rstudio-server...
May 21 13:32:06 HP-EliteDesk-800-G1-TWR systemd[1]: Failed to star...
May 21 13:32:06 HP-EliteDesk-800-G1-TWR systemd[1]: rstudio-server...
May 21 13:32:06 HP-EliteDesk-800-G1-TWR systemd[1]: rstudio-server...
Hint: Some lines were ellipsized, use -l to show in full.

Then I tried rstudio-server start which produced:

/usr/lib/rstudio-server/bin/rserver: error while loading shared libraries: cannot open shared object file: No such file or directory

Based on this I went for installing libssl by sudo apt-get install libssl1.0.0 libssl-dev which resulted in:

Reading package lists... Done
Building dependency tree
Reading state information... Done
libssl-dev is already the newest version (1.0.2g-1ubuntu4.12).
libssl1.0.0 is already the newest version (1.0.2g-1ubuntu4.12).
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.

Considering the version numbers in parenthesis, I have the correct version, plus Rstudio server version 1.1.445 was working fine on my computer.

I couldn't find any relevant post in StackOverflow or this forum. Any ideas?

1 Like

It seems that it is not only me who have faced this issue. I stumbled upon the following link in the first page of googling about this:

I'm sure that my openssl version is correct and I have downloaded the last .deb package from rstudio website, so things are expected to work. Just for the sake of the argument:

➜  ~  openssl version
OpenSSL 1.0.2n  7 Dec 2017

➜  ~  apt search libssl | grep "^libssl"

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

libssl-dev/xenial-updates,xenial-security,now 1.0.2g-1ubuntu4.12 amd64 [installed]
libssl-doc/xenial-updates,xenial-updates,xenial-security,xenial-security,now 1.0.2g-1ubuntu4.12 all [installed,automatic]
libssl-ocaml/xenial 0.5.2-1 amd64
libssl-ocaml-dev/xenial 0.5.2-1 amd64
libssl1.0.0/xenial-updates,xenial-security,now 1.0.2g-1ubuntu4.12 amd64 [installed]
libssl1.0.0-dbg/xenial-updates,xenial-security 1.0.2g-1ubuntu4.12 amd64
libsslcommon2/xenial 0.16-9ubuntu2 amd64
libsslcommon2-dev/xenial 0.16-9ubuntu2 amd64

I need this to work and I appreciate any help.

I've hit the same. Can't make this work until it's fixed or there's a workaround

/usr/lib/rstudio-server/bin/rserver: error while loading shared libraries: cannot open shared object file:

Do you know anyone from the support team or any experienced member that can help us dig into this and solve this? We can tag them here for example

As a bit of an update, After discussing with a colleague of mine, he suggested that I check what is used during compilation of rstudio server:

ldd /usr/lib/rstudio-server/bin/rserver

/usr/lib/rstudio-server/bin/rserver: /usr/lib/ version `OPENSSL_1.0.2d' not found (required by /usr/lib/rstudio-server/bin/rserver) => (0x00007ffd85bfc000) => /lib/x86_64-linux-gnu/ (0x00007ffa64e62000) => /lib/x86_64-linux-gnu/ (0x00007ffa64c45000) => /lib/x86_64-linux-gnu/ (0x00007ffa64a42000) => /lib/x86_64-linux-gnu/ (0x00007ffa6483d000) => /lib/x86_64-linux-gnu/ (0x00007ffa64635000) => /lib/x86_64-linux-gnu/ (0x00007ffa6441b000) => /usr/lib/ (0x00007ffa641b2000) => not found => /lib/x86_64-linux-gnu/ (0x00007ffa63fa4000) => /usr/lib/x86_64-linux-gnu/ (0x00007ffa63c22000) => /lib/x86_64-linux-gnu/ (0x00007ffa63919000) => /lib/x86_64-linux-gnu/ (0x00007ffa63703000) => /lib/x86_64-linux-gnu/ (0x00007ffa63339000)
/lib64/ (0x00007ffa6581e000) => /lib/x86_64-linux-gnu/ (0x00007ffa62ef5000) => /lib/x86_64-linux-gnu/ (0x00007ffa62cce000)

The only one missing is , so I searched in Ubuntu repository to see which package has this file:

sudo apt install apt-file
apt-file update
apt-file find

This resulted in

libssl-dev: /usr/lib/x86_64-linux-gnu/
libssl1.0.0: /lib/x86_64-linux-gnu/

which means the file does not exist in the Ubuntu repository (my system is Ubuntu 16.04)

Then, it was time to check the package versions used in in the compiled file:

strings /usr/lib/rstudio-server/bin/rserver | grep OPENSSL


This shows that OPENSSL_1.0.2d is used all through out the compilation (the focus is on the minor version "d" at the end of the library name)

Then, finally it was time to check what is provided in the latest version that I could find in Ubuntu repository:

strings /usr/lib/ | grep OPENSSL           

OPENSSL_DIR_read(&ctx, '
OPENSSL_malloc Error

As you can see there is no 1.0.2d version. This simply means that Rstudio people have most probably changed their .deb building workflow!!!!!

For those who are stuck like me in this situation, the only way left is to download, complile and install Rstusio Server them selves on their own computer:

Do you have any better luck installing the binary for Debian 8 / Ubuntu? From :

$ sudo apt-get install gdebi-core
$ wget
$ sudo gdebi rstudio-server-1.1.453-amd64.deb

Thanks for the help and pointing out my mistake. Yes it works when I use the correct .deb file :man_facepalming: . I think the header "Debian 8 / Ubuntu" is not as eye-catching and as bold as "64bit". Perhaps it would be nice to change the header color or draw a horizontal line between these two sections.

Thank you for your reply and thanks for saving my time.


I am having exactly the same problem. Reding through this thread I understand the problem is now resolved but I can't see how was it resolved. I would appreciate if you kindly specifiy what exactly you did to resolve? Thanks

Got it. I had to read the lines of code again to see the slight difference between Debian 8 and Debian 9+.
It really is error prone. Thanks

1 Like

I'm having the same issues whether I use the debian package or compile from source. I used softlinks to handle the version 1.0.2 issue of libssl and libcrypto.

root@behemoth:/lib/x86_64-linux-gnu# ldd /usr/lib/rstudio-server/bin/rserver
/usr/lib/rstudio-server/bin/rserver: /lib/x86_64-linux-gnu/ version `OPENSSL_1.0.2d' not found (required by / usr/lib/rstudio-server/bin/rserver) => (0x00007ffed98b1000) => /lib/x86_64-linux-gnu/ (0x00007f6de3067000) => /lib/x86_64-linux-gnu/ (0x00007f6de2e4a000) => /lib/x86_64-linux-gnu/ (0x00007f6de2c47000) => /lib/x86_64-linux-gnu/ (0x00007f6de2a42000) => /lib/x86_64-linux-gnu/ (0x00007f6de283a000) => /lib/x86_64-linux-gnu/ (0x00007f6de2620000) => not found => /lib/x86_64-linux-gnu/ (0x00007f6de21db000) => /lib/x86_64-linux-gnu/ (0x00007f6de1fcd000) => /usr/lib/x86_64-linux-gnu/ (0x00007f6de1c4b000) => /lib/x86_64-linux-gnu/ (0x00007f6de1942000) => /lib/x86_64-linux-gnu/ (0x00007f6de172c000) => /lib/x86_64-linux-gnu/ (0x00007f6de1362000)
/lib64/ (0x00007f6de3a23000) => /lib/x86_64-linux-gnu/ (0x00007f6de113b000)

Has anyone been able to get this to work on ubuntu 16?????

See the above - did you use the right .deb file? (i.e. 32 bit vs. 64 bit, right operating system, etc.)?

1 Like

Yep, I used the right version of the deb file. Also installed by compiling the source. Same result both times. This is the OPENSSL_1.0.2d issue. the version that comes with ubuntu 16 is 1.0.2g. I can't downgrade it without potentially causing issues with the rest of the server.

I symlinked the libssl and libcrypto libraries to even get that far. It seems others have had the same issue. It appears we can't install rstudio-server on ubuntu 16.

The file I downloaded is rstudio-server-stretch-1.1.463-amd64.deb

OMG I just realized I may have downloaded the wrong file :slight_smile:
I downloaded the one for Debian 9+. I guess the one I should use is for Debian 8/Ubuntu?

UPDATE: Yes, folks, I had installed the wrong DEB file. for Ubuntu, use the Debian 8 one. For some weird reason, a number of us are reading the instructions wrong and try to install the Debian 9+ one on Ubuntu 16.


Thanks for the update! I think this number of errors indicates more than just a user issue :smile: We will pass the info along to our webdesign team!