RStudio running super slowly; can't access global options menu and uninstall / re-install doesn't sove the issue

Hi All - I'm a newbie, but I'll try to be very clear about my issue and thanks in advance for your time!

I've been trying to run a simple R script I wrote to read in a series of PDFs and output a new, single file.

Now, I'm getting really buggy behavior:

  • My scripts won't save properly even with an explicit "save" or ctrl-S
  • I can't close my session without going through task manager
  • when I try to run any script or even type in a simple commend in the console, nothing happens - and I can't seem to break out whatever routine is running.

I've tried looking for solutions online, and it seems that I'd want to try disabling diagnostics or resetting RStudio's desktop state. But both of these require that I'm able to access the Tools -> Global options menu, which I'm not able to do. When I try, nothing happens.

I've tried uninstalling and reinstalling a few times (even tried an earlier version) to no avail.

Can anyone help?

Thanks so much.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.