RStudio - Quarto Problems

I love Quarto. Use it to make my Jupyter Notebooks look as good as my RMarkdown files. BUT, I cannot get it to work in RStudio my primary IDE running Windows 11.

The error is upon rendering a blog is:
Access is denied. (os error 5), ....cliffblog\index_files

index_files is read only and even as Admin, I cannot change permissions.

Creating and rendering a new Quarto file works fine. It is the creation of the blog index_files that is the problem.

Also, there is no Quarto tab option in Tools-->Global Options-->R Markdown.

What I have done:

  • uninstalled Quarto and RStudio rebooting each time. Then I have -
  1. Installed only RStudio current release (2022.07.2)
    • No change, same problems
  2. Installed current releases of Quarto then installed RStudio
    • No change, same problems

And yes, I ran RStudio as an Adminstrator.

Quarto is installed and works, just not in RStudio.

quarto --version

When I installed Quarto before installing RStudio, I used Quarto version 1.3.47

The code is super simple:

title: "Cliff's Document Repository"
  contents: posts
  sort: "date desc"
  type: default
  categories: true
  sort-ui: false
  filter-ui: false
page-layout: full
title-block-banner: true

This is a Quarto Blog site that hosts a number of documents that demonstrate R and Python projects.

I am desperate to use Quarto in RStudio but there is little information on the web to help. Hoping someone here can get me going in the right direction. After many years of using RStudio nearly every day, this is the first time I have been stumped.


I had some 'success' creating a Quarto website by using the menu structure in RStudio:
File | New Project | New Directory | Quarto Website
It generates the files needed for the website with some example 'entries'.
Maybe this also works for you.

Thank you for your input. Unfortunately, Access Denied on index_files occurs when trying to start a Quarto Website too.

Even manually reproducing the folder structure results in Access Denied to index_files even though I created the folder. Once I attempt to render, RStudio is applying read only access and I cannot change it even though I am a full administrator.

So frustrating.

OK. Problem solved - kinda.

I use an SD Card to store all my development work. If I create a new Quarto Project that creates an index_files folder in the D: drive, it fails with Access Denied. If I repeat this on by C: Drive, everything works as expected.

It is very inconvenient to have to store Quarto Projects on a different drive, but to complete my current project, I must.

I hope this experience is helpful for others. Perhaps RStudio might consider this as a bug since I should be able to create projects anywhere I please. I understand that this is a Windows isse but we all have to work around the problems Microsoft often challenges us with.

1 Like

After reading your message I used a USB stick to create a website there.
I can confirm the error message

Access is denied. (os error 5), stat 'K:\TestHan\quartoproj\index_files'
PermissionDenied: Access is denied. (os error 5), stat 'K:\TestHan\quartoproj\index_files'

I think you should open an issue in

So that this is tracked somewhere.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.