RStudio QT xkeyboard issue in a Ubuntu VNC

I have had this problem for the past 2 weeks (since the server has been setup);

I installed the newest version of R v3.4.4 on our Ubuntu 16.04 LTS. I can type in the terminal "R" and R will come up with no problems, and I can install and run functions from there.

Now I installed R Studio 1.1.453 and I can open it from a terminal using "rstudio"; however I get this error when I open it from a terminal:

Qt: XKEYBOARD extension not present on the X server.
Could not initialize OpenGL for RasterGLSurface, reverting to RasterSurface.
load glyph failed err=6 face=0x24d2270, glyph=2797
load glyph failed err=6 face=0x24d2270, glyph=2797
qt_xcb_createCursorXRender: query_pict_formats failed
Segmentation fault (core dumped)

I tried to revert back to an older version of RStudio as I read in a lot of help forms and that didnt help, right now I am running 0.98.1103 for RStudios and it comes out with the error:

Segmentation Fault (core dumped)

and doesnt move past this. least the newer version of RStudio will actually open up.

I also read it was the VNC I am using, but I have tried several different VNC: tight, tiger, turbo...
I would like to move on from this issue.. I need a work around for the VNC, but if that is the true issue then I need to come up with another game plan.

Do you have any better luck with the preview release of RStudio?

@kevinushey Thank you I will take a look into that when our server gets restarted (unfortunately its a VNC not at our facility so I dont have complete access to it), it is frozen when I was trying to open up a folder to try and find a configuration file.

@kevinushey So I tried the preview version and got a different error but this time it couldnt even open rstudios up.

So no luck...

Qt: XKEYBOARD extension not present on the X server.
[17446:17497:0628/] Failed to load /usr/lib/rstudio/bin/ /usr/lib/rstudio/bin/ cannot open shared object file: No such file or directory
The X11 connection broke: Maximum allowed requested length exceeded (code 4)
XIO:  fatal IO error 2 (No such file or directory) on X server ":1"
      after 228 requests (220 known processed) with 0 events remaining.
[17502:17502:0100/] Invalid node channel message

It sounds like this will be fixed in Qt 5.11.1, which we plan to upgrade to in the near future (at least, we will in time for the RStudio v1.2 release).

The associated Qt bug report is here: It sounds like there should be a workaround -- you can try running


to workaround the issue for now.

I have tried that command before "export XKB_DEFAULT_RULES=base"

And it doesnt do anything, however I dont think I have QT installed. I tried looking that up today, but stopped because I didnt think I was doing it right.

I am going to use this guide to install QT 5.11.1, will that be compatible with RStudio 1.1.453?
[](http://Install Qt5 On Ubuntu)


chmod -x

RStudio bundles and uses it own version of Qt by default, so installing your own copy of Qt won't make a difference here.

Whats the best plan of action?

I know it is not R itself, because I can use the command R and type in R perfectly fine, its when R is associated with the GUI RStudios that RStudios cannot read the keybaord.

Should I try older versions of RStudio?
Any virtual keyboard extensions I can install?