RStudio pulls up old files and is locked up.

This is a new issue as I have been running code recently and have had no problems but one day, RStudio pulled up a bunch of old files. I was able to close them, but I was unable to create a new script or new project. When I try to execute basic code, it will not execute. When I try to restart R, it will not restart, and I am required to force quite the program in order to close it. I have also tried to open options such as "global options" and the window will not pull up. As a note, I am able to write code in R but have many projects going on right now that use RStudio.

I have tried a couple of fixes such as deleting the RData files associated with these projects but have had no luck. I also tried to find ~.RData folder using powershell but it was unable to find it even after I enabled view hidden files. I have also tried deleting RStudio and R off of my computer and then reinstalling. When I did this, it just pulled up the same files and still had the same issues.

For reference, I have a Lenovo Carbon X9 running windows 11 running RStudio Version: 2023.12.0+36. If there is anymore information that may help solve this issue, please let me know.

Try uninstalling RStudio (I think it's safe to leave R alone), then manually delete these two directories: C:\Users<you>\AppData\Local\RStudio and C:\Users<you>\AppData\Roaming\RStudio. Then reinstall RStudio and hope for the best.

That appeared to do it! Thank you so much for your help!

This topic was automatically closed 42 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.