RStudio Preview - screen resolution problem


I have a problem with the screen resolution of the preview version RStudio-1.2.1015. As you can see in the attached screenshot, the resolution is blurry, the menu bar is not visible and the individual tabs are not all clickable. This makes RStudio unfortunately unusable...

I've already completely uninstalled and reinstalled Rstudio several times without success. The currently "productive" version RStudio-1.1.456 works fine for me, so it must be due to the preview version. I have already tested two other preview versions, but they have the same errors.

Is the problem known to you? What I have to say is that a co-worker has the same version installed and it works for him.

I need the preview version because of the Python integration.

PS: Is there already a release date for RStudio 1.2?

Thanks in advance!

I won't be able to solve your problem, but for people who might be able to, you'll need to provide more info about the setup you are using.
For example, what OS are you running? Do you use multiple monitors? Is menu bar responsive if you use Alt, for example?

Sorry, here the required information:

R version 3.5.1 (2018-07-02)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows >= 8 x64 (build 9200)

I'm working on several monitors, but the problems are the same on my notebook. And no, the menu bar doesn't response if I press Alt.

1 Like

What kind of computer do you have? What kind of graphics card is installed on that computer?

I have a Lenovo X270 with a Intel Graphics 620.

The latest preview release is currently v1.2.1030 -- can you try downloading that and let me know if the situation is at all improved?

I tried the version 2.1030 already and I got the same problems.

I have just downloaded the ZIP version and it works strangely. Is there a reason for that?

I can't think of any reason why the installer would have this issue but the zipped version wouldn't -- after installation, they should unpack to exactly the same contents.

I faced a similar problem on Windows10. It was solved by updating the intel graphics driver.