RStudio on Win 7 hangs while I am typing a command

I am looking forward to using R via RStudio to plot a series of blood pressure readings, but I have run into a problem.

As I am trying to learn, I find that RStudio hangs quite often as I am typing in a command. It usually responds after some minutes.

Do you know if there is a fix for this?

Or any package for doing what I want to do? (ie. plot values in several parameters in a time series)

Machine is a Dell Latitude E6440, 64-bit with Win 7, SP1, processor: Intel Core i7-4610M, 3.0ghz, has 16 gigs of memory,

Thanks for thinking about these things,


Some more system information would also be helpful. Here's what's suggested on the RStudio Crashed support page:

Information about your system

  • Version of RStudio (including whether it's Desktop or Server)
  • Output from running sessionInfo() in standard R console

Information about the crash

  • Description of crash
  • Steps to reproduce
  • Related R code or packages
  • Error messages
  • Screenshots
  • Log files
  • Crash Report

For diagnostic reports, crash reports, or log files, you may wind up with output that is too long to paste in here. Please share it somewhere else (Google Drive, GitHub gist, Dropbox, etc) and link to it here. For your own security, please make sure you delete any sensitive information (e.g., your computer's IP address) before posting.

Thanks, ,
The software versions of the installers that I used are:

RStudio doesn't crash, it just igpanenores me for some minutes and then pays attention again. Spcifically, the blinking cursor stops blinking for that time. This happens in the script window pane and in the console window pane. The Maximise and Restore buttons of the outer window still function during this pause.

The session log is empty, and the rdesktop log shows:
14 Nov 2019 05:19:38 [rdesktop] ERROR Main window closed unexpectedly; LOGGED FROM: auto __cdecl rstudio::desktop::MainWindow::closeEvent::<lambda_9193e8662378f0135bda1ce57e06be4d>::operator ()(class QVariant) const C:\jenkins\workspace\IDE\windows-v1.2\src\cpp\desktop\DesktopMainWindow.cpp:284

I think that was from when I tried to exit RStudio, and was only able to do it by clicking the X button on the window.

Here's the output of sessionInfo():
R version 3.6.1 (2019-07-05)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows 7 x64 (build 7601) Service Pack 1

Matrix products: default

[1] LC_COLLATE=English_Australia.1252 LC_CTYPE=English_Australia.1252
[3] LC_MONETARY=English_Australia.1252 LC_NUMERIC=C
[5] LC_TIME=English_Australia.1252

attached base packages:
[1] stats graphics grDevices utils datasets methods base

other attached packages:
[1] forcats_0.4.0 stringr_1.4.0 dplyr_0.8.3 purrr_0.3.3
[5] readr_1.3.1 tidyr_1.0.0 tibble_2.1.3 ggplot2_3.2.1
[9] tidyverse_1.2.1

loaded via a namespace (and not attached):
[1] Rcpp_1.0.3 cellranger_1.1.0 pillar_1.4.2 compiler_3.6.1
[5] tools_3.6.1 digest_0.6.22 zeallot_0.1.0 viridisLite_0.3.0
[9] jsonlite_1.6 lubridate_1.7.4 lifecycle_0.1.0 nlme_3.1-140
[13] gtable_0.3.0 lattice_0.20-38 pkgconfig_2.0.3 rlang_0.4.1
[17] cli_1.1.0 rstudioapi_0.10 haven_2.2.0 withr_2.1.2
[21] xml2_1.2.2 httr_1.4.1 generics_0.0.2 vctrs_0.2.0
[25] hms_0.5.2 grid_3.6.1 tidyselect_0.2.5 glue_1.3.1
[29] R6_2.4.1 fansi_0.4.0 readxl_1.3.1 modelr_0.1.5
[33] magrittr_1.5 backports_1.1.5 scales_1.0.0 rvest_0.3.5
[37] assertthat_0.2.1 colorspace_1.4-1 labeling_0.3 utf8_1.1.4
[41] stringi_1.4.3 lazyeval_0.2.2 munsell_0.5.0 broom_0.5.2
[45] crayon_1.3.4

Hope that information gives you some ideas,

Also, while RStudio is ignoring me, I can move the mouse pointer around in the program, and it appears as crosshairs (ie like "+").

Maybe that helps.

Well, now while it is ignoring me the mouse cursor is an I-beam, as you would expect in the script pane and the console pane.

Do you have a project open when this issue occurs? Do you observe the same behavior in other projects, as well?

Are you working with a project on a network filesystem, by any chance?

Any other information you can share about your environment would be helpful.

Yes, I have a project open when RStudio hangs.
Yes, I have just downloaded a sample project and opened it as a new project. I was reading through the comments at the start of the script and RStudio stopped responding. A minute or so later the cursor started blinking again.
I just tried (with Ctrl-Enter) to run the line:

data(diamonds, package = "ggplot2")

and RStudio ignored me for a couple of minutes, and is now being responsive again.

No, I am running this on my PC, on its C drive. It is connected to a LAN which has internet access through a NAT router, but I don't think anything is waiting for a network connection.

By the way, I have been able to produce the plot that I wanted from tab-separated values in a text file out of Excel.

Thanks again for thinking about this,

Strange! Unfortunately, diagnosing these issues can often be quite challenging.

If you haven't already, you can try resetting RStudio's state:

Do you have a large number of packages installed? What is the output of:


You might also try generating an R profile and sharing that with us.

It's possible some of the slowness is caused by R code that RStudio is running behind the scenes. Can you try running an R profile? Try the following:

Within R, execute:


to edit your global .Rprofile. In that file, try adding:


After doing this, close RStudio, then re-launch it. After RStudio has successfully launched, use the IDE until you observe slowness in the IDE. After that has resolved, run:


Then, find the file at "~/rstudio-trace.Rprof", and share it with us.

You can also try sharing the printed output of


directly, as that may point us towards what we need to know.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.