RStudio on M1 MacBook installation issue

I'm trying to install R and RStudio on a new M1 Mac. It's not my first time doing this (I've done it twice before). The R installation is fine (I am using the Apple silicone CRAN binary).

R version 4.1.1 (2021-08-10) -- "Kick Things"
Copyright (C) 2021 The R Foundation for Statistical Computing
Platform: aarch64-apple-darwin20 (64-bit)

Something seems to be wrong with the RStudio build. I do not seem to have a choice (Intel or Apple silicone version) when downloading RStudio Desktop. Installing from the .dmg results in the Intel version being installed. When I try to launch RStudio, I get a popup asking me to install / enable Rosetta2.

The RStudio Desktop version I am trying to install is 2021.09.0+351 (the latest stable build).

I was under the impression there is a native Apple silicone version. Am I wrong?

No native version of RStudio Desktop but the Intel version is compatible with native R.

1 Like

Thanks. For some reason, I don't remember having to install Rosetta2 to run RStudio before. Maybe my memory is just starting to fail.

Yes this is expected. We don't have a native M1 build of the RStudio IDE yet, but you can run RStudio fine using Rosetta2, and it will make use of the native M1 R binaries. So your R code will be executed natively on the M1, which is the main aspect of performance anyway.

1 Like

First I tried R-4.1.1.pkg on my M1Mac 2020 It doesn't work good, I'm using WGCNA on RStudio and it had 14 hours processing data and it doesn't finish, because I stopped. I should mention that my computer's teacher has intel Mac and the same analysis took for him just 1 hour. Then I tried the version R-4.1.1-arm64.pkg and I can´t install WGCNA. What to do?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.