RStudio not working after updating to Mac OS Monterey 12.0.1

Just updated to Mac OS Monterey, which resulted in dysfunctioning Rstudio. The program starts, but the main window remains "blank". No response to opening files. Can right-click, with few possible options, but nothing changes.

Cannot enter preferences, but all top-menu options are available, with no real effect.

R as a standalone has normal functionality.

No effect of reinstallation of Rstudio and/or R.

Any suggestions to a solution would be very much appreciated!


Have you tried forcing RStudio to use software rendering?

My problem is a little different:

Mac mid 2015, just updated to Monterey

Can you try reinstalling R using the official installer? R for macOS


Sorry for the slow response.

I since I am not able to open anything I don’t know how I would be able to change the rendering.

Ultimately, I decided to go back to Big Sur which solved the problem. However, I hope to be able to update to Monterey in the near future. Hope that the problem doesn’t repeat.


Thanks a lot - you saved my day - I had started looking at the most peculiar places, and would have destroyed more than I have saved. Now it's up and running

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.