RStudio Not Starting on Sierra

Error Information:

Description of issue - When I try to start RStudio on my mac (OS Sierra) it goes to "Not Responding" and I have to force quit.

Attempted steps taken to fix - I tried deleting R and R Studio and re-downloading the newest versions, I deleted the .rstudio-desktop folder and all startup files I could find, I don't have a firewall, and when I put "Sys.which("R")" into my Terminal it said "-bash: syntax error near unexpected token `"R"' ". I did the first-aid on Disk Utility and restarted my computer. I've tried to read through each ticket about this issue but none of those fixes seem to be working for me. I've used RStudio for years and have never had an issue and can't think of anything that's changed on my computer to prevent it.

System Information:

- RStudio Edition: Desktop
- RStudio Version: 1.1.456
- OS Version: Sierra
- R Version: R 3.5.1 
- Output your diagnostics report (if possible): 
Diagnostics report:

[1] "1.1.456"

[1] "/usr/local/bin/R"

[1] ""

[1] ""

[1] "/usr/bin/gcc"

[1] "/usr/bin/git"

[1] "/usr/bin/svn"

R version 3.5.1 (2018-07-02)
Platform: x86_64-apple-darwin15.6.0 (64-bit)
Running under: macOS Sierra 10.12.6

Matrix products: default
BLAS: /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libBLAS.dylib
LAPACK: /Library/Frameworks/R.framework/Versions/3.5/Resources/lib/libRlapack.dylib

[1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

loaded via a namespace (and not attached):
[1] compiler_3.5.1 tools_3.5.1   

"Darwin Kernel Version 16.7.0: Thu Jun 15 17:36:27 PDT 2017; root:xnu-3789.70.16~2/RELEASE_X86_64" 

R Version:
platform       x86_64-apple-darwin15.6.0   
arch           x86_64                      
os             darwin15.6.0                
system         x86_64, darwin15.6.0        
major          3                           
minor          5.1                         
year           2018                        
month          07                          
day            02                          
svn rev        74947                       
language       R                           
version.string R version 3.5.1 (2018-07-02)
nickname       Feather Spray               
[1] "/Applications/"

[1] "0x1F5:0x0:0x0"

[1] "/private/tmp/"

[1] "1"

[1] "/Library/Frameworks/R.framework/Resources/lib:/Users/brittanysawrey/lib:/usr/local/lib:/usr/lib:::/lib:/Library/Java/JavaVirtualMachines/jdk-9.jdk/Contents/Home/lib/server"

[1] "vi"

[1] "rpostback-askpass"

[1] "/Users/brittanysawrey"

[1] "en_US.UTF-8"

[1] "en_US.UTF-8"

[1] "ln -s"

[1] "brittanysawrey"

[1] "make"

[1] "/usr/bin/less"

[1] "/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin"

[1] "/Users/brittanysawrey"

[1] "/usr/bin/open"

[1] "/usr/bin/bzip2"

[1] "/Library/Frameworks/R.framework/Resources/doc"

[1] "/usr/bin/gzip"

[1] "/Library/Frameworks/R.framework/Resources"

[1] "/Library/Frameworks/R.framework/Resources/include"

[1] ""

[1] "~/Library/R/3.5/library"

[1] "a4"

[1] "/usr/bin/open"

[1] "x86_64-apple-darwin15.6.0"

[1] "lpr"

[1] "/Library/Frameworks/R.framework/Resources/bin/qpdf"

[1] "times,inconsolata,hyper"

[1] "/var/folders/9x/c6p8xh5970ddw41mzmspyg6m0000gn/T//Rtmpy9J5tE"

[1] "/Library/Frameworks/R.framework/Resources/share"

[1] "osx,gcc,gxx,gfortran,?"

[1] "/usr/local/bin/texi2dvi"

[1] "/usr/bin/unzip"

[1] "/usr/bin/zip"

[1] "/Applications/"

[1] "/Applications/"

[1] "a12fafce-d040-4555-aab9-94313fece5e6"

[1] "1"

[1] "256"

[1] "80"

[1] "/Applications/"

[1] "22750"

[1] "brittanysawrey"

[1] "bin/winutils"

[1] "/usr/bin/sed"

[1] "/bin/bash"

[1] "1"

[1] "rpostback-askpass"

[1] "/private/tmp/"

[1] "/usr/bin/tar"

[1] "xterm-256color"

[1] "Apple_Terminal"

[1] "388.1.1"

[1] "2BF4FB20-AF76-4C1D-B9FD-843C559D05DA"

[1] "/var/folders/9x/c6p8xh5970ddw41mzmspyg6m0000gn/T/"

[1] "brittanysawrey"

[1] "0x0"

[1] "0"

 [1] ".GlobalEnv"        "tools:rstudio"     "package:stats"    
 [4] "package:graphics"  "package:grDevices" "package:utils"    
 [7] "package:datasets"  "package:methods"   "Autoloads"        
[10] "package:base"     
Log file: rdesktop.log

From RStudio Desktop Will Not Start on

Sorry to hear you're having trouble! I don't think I can directly help much, but to clear up one minor point:

Sys.which() is an R function, so Terminal doesn't know what to do with it, hence the bash error message. The "RStudio Desktop Will Not Start" support page could stand to be clearer about this, but when it says "Open a standard console session (RGui,, Terminal, etc)" it means open an R session outside of RStudio. You can do this on MacOS by opening, or by opening Terminal and entering: R at the prompt. Anyway, not a big deal since the diagnostic output you included contains the same information!

Two questions which might come up while troubleshooting this issue:

  • Can you confirm that R runs outside of RStudio (e.g. by launching or running R in Terminal, as described above)?
  • Do you have the same problem if you install the current preview release of RStudio?

Thank you so much for this response! Your explanation of Sys.which() makes perfect sense, thanks for clarifying. Yes, R runs outside of RStudio just fine, and I just downloaded the preview release and that is working! Can I just use that, or does that lead us closer to finding the issue?

Thank you!


If 1.2 is working for you, you can definitely just chalk this up to :woman_shrugging: and get back to work!

The fact that it works suggests that whatever was wrong may have already been fixed on the RStudio end (on purpose, or as a side effect of other improvements). Can you identify any changes you made to your system that coincided with the problem appearing? (off the top of my head: R version update? OS update? Other software installation? Change in network environment?) It's OK if not! Since you've got a working (newer and shinier) version of RStudio now, there may not be much benefit to further troubleshooting, especially if the problem is something really system-specific and rare.