RStudio not opening on Mac 10.14.6

Error Information: I can't open RStudio after a fresh install

Description of issue

  • After installing the latest version of R (4.1.2), I downloaded the recommended RStudio installer, and installed it. However, after installing, I get an error that says " RStudio cannot be opened because of a problem."

Attempted steps taken to fix -
I tried a bunch of random stackoverflow terminal commands that people said helped when they couldn't start rstudio on mac. I also tried to look at the Desktop Will Not Start page, but some of the steps are difficult for me (a non programmer) to follow.
The startup file thing was confusing,

I tried copy-pasting sys.which("R") in terminal, but got

-bash: syntax error near unexpected token `"R"'

I checked with my partner, and it doesn't seem like it should be a firewall/proxy setting/antimalware problem

I would LOVE some beginner friendly help with this. Really want to dig into learning R! Thanks so much. :slight_smile:

System Information:

  • RStudio Edition: Desktop
  • RStudio Version: 2022.02.0+443
  • OS Version: Mojave 10.14.6
  • R Version: 4.1.2
  • Output your diagnostics report (if possible):
    here's what comes out when I get the details to send to apple:

Process: RStudio [40438]
Path: /Applications/
Identifier: org.rstudio.RStudio
Version: 2022.02.0+443 (2022.02.0+443)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: RStudio [40438]
User ID: 501

Date/Time: 2022-02-22 22:19:01.142 -0800
OS Version: Mac OS X 10.14.6 (18G9323)
Report Version: 12
Bridge OS Version: 5.5 (18P4759a)
Anonymous UUID: 6193F359-36BA-6917-60EE-9FC6C392B864

Time Awake Since Boot: 2500 seconds

System Integrity Protection: enabled

Crashed Thread: 0

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Termination Reason: DYLD, [0x1] Library missing

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
Library not loaded: @executable_path/../Frameworks/libssl.1.1.dylib
Referenced from: /Applications/
Reason: no suitable image found. Did find:
/Applications/ cannot load 'libssl.1.1.dylib' (load command 0x80000034 is unknown)
/Applications/ stat() failed with errno=1
/Applications/ cannot load 'libssl.1.1.dylib' (load command 0x80000034 is unknown)
/Applications/ stat() failed with errno=1

Binary Images:
0x10b9ea000 - 0x10bc89ff7 +org.rstudio.RStudio (2022.02.0+443 - 2022.02.0+443) <8FCA55E4-F99C-3C2D-836C-F83DBD48C5FF> /Applications/
0x10bcfa000 - 0x10bd26ff3 +org.qt-project.QtWebEngine (5.12 - 5.12.10) /Applications/
0x10bd67000 - 0x10bd86ff7 +org.qt-project.QtWebEngineWidgets (5.12 - 5.12.10) /Applications/
0x10bdb2000 - 0x10bddbff7 +org.qt-project.QtPrintSupport (5.12 - 5.12.10) <223CF25F-E06A-30A9-8DBD-220F03A309CC> /Applications/
0x10be09000 - 0x10be14ff3 +org.qt-project.QtQuickWidgets (5.12 - 5.12.10) <422C060F-23AA-3AFA-BBCF-579922813702> /Applications/
0x10be28000 - 0x10be40ff3 +org.qt-project.QtSensors (5.12 - 5.12.10) <60979C61-7509-39A5-B67B-B19E37CB4176> /Applications/
0x10be65000 - 0x10be99fff +org.qt-project.QtSvg (5.12 - 5.12.10) <03F912BA-0798-34C3-B6A8-1D25EF990C99> /Applications/
0x10bec5000 - 0x10bef6fff +org.qt-project.QtXml (5.12 - 5.12.10) <8B53E31A-3627-33B0-9F10-E017066AB9E6> /Applications/
0x10bf11000 - 0x10c216ff3 +org.qt-project.QtXmlPatterns (5.12 - 5.12.10) /Applications/
0x10c275000 - 0x1124b7fcf +org.qt-project.Qt.QtWebEngineCore (5.12 - 5.12.10) <3D82741E-7F62-3F99-A216-B71C9A621440> /Applications/
0x112bae000 - 0x112bc3ff7 +org.qt-project.QtWebChannel (5.12 - 5.12.10) /Applications/
0x112bd8000 - 0x112c3bffb +org.qt-project.QtPositioning (5.12 - 5.12.10) /Applications/
0x112c5f000 - 0x112f4dfff +org.qt-project.QtQuick (5.12 - 5.12.10) <6F9F327D-37CB-3A63-B346-6ABB235ED3B2> /Applications/
0x11306b000 - 0x1133e5ff7 +org.qt-project.QtQml (5.12 - 5.12.10) /Applications/
0x1134a4000 - 0x1138e2ff7 +org.qt-project.QtWidgets (5.12 - 5.12.10) <6B09C0AD-B709-3310-ABDE-9482BADCED3E> /Applications/
0x113a57000 - 0x113ea5ff7 +org.qt-project.QtGui (5.12 - 5.12.10) <56F11200-E996-39AD-8030-3EB73DA1F954> /Applications/
0x113fbf000 - 0x1140c9ff7 +org.qt-project.QtNetwork (5.12 - 5.12.10) /Applications/
0x114120000 - 0x114656ff7 +org.qt-project.QtCore (5.12 - 5.12.10) /Applications/
0x114724000 - 0x11475bfff +libpq.5.dylib (0) <63C417A0-8261-375D-8C20-D27999F21952> /Applications/
0x1191da000 - 0x11924470f dyld (655.1.1) <4842B61A-B868-3146-9CA9-5582C4198B25> /usr/lib/dyld
0x7fff311b6000 - 0x7fff311b6fff (50.1 - 50.1) <4B219825-98FE-3972-8687-47114A18C541> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/ApplicationServices
0x7fff32524000 - 0x7fff32524fff (6.11 - 23) <4D068A12-9E8F-3264-88BA-8426A9849AE3> /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa
0x7fff33ff1000 - 0x7fff33ff1fff (947.2 - 947.2) <7BD142C3-402B-3294-BE74-9DD4623827E4> /System/Library/Frameworks/CoreServices.framework/Versions/A/CoreServices
0x7fff3e2f4000 - 0x7fff3e5f5ff7 (7.0 - 58286.270.14) /System/Library/Frameworks/Security.framework/Versions/A/Security
0x7fff5bea5000 - 0x7fff5bea6ffb libSystem.B.dylib (1252.250.1) /usr/lib/libSystem.B.dylib
0x7fff5e036000 - 0x7fff5e213fff libsqlite3.dylib (274.26) <6404BA3B-BCA4-301F-B2FE-8776105A2AA3> /usr/lib/libsqlite3.dylib
0x7fff5e54f000 - 0x7fff5e561ff7 libz.1.dylib (70.200.4) /usr/lib/libz.1.dylib

Model: MacBookPro15,1, BootROM 1554. (iBridge: 18.16.14759.0.1,0), 6 processors, Intel Core i7, 2.6 GHz, 16 GB, SMC
Graphics: kHW_IntelUHDGraphics630Item, Intel UHD Graphics 630, spdisplays_builtin
Graphics: kHW_AMDRadeonPro560XItem, Radeon Pro 560X, spdisplays_pcie_device, 4 GB
Memory Module: BANK 0/ChannelA-DIMM0, 8 GB, DDR4, 2400 MHz, Micron, 8ATF1G64HZ-2G6E1
Memory Module: BANK 2/ChannelB-DIMM0, 8 GB, DDR4, 2400 MHz, Micron, 8ATF1G64HZ-2G6E1
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x7BF), wl0: Oct 23 2019 08:32:36 version FWID 01-671ec60c
Bluetooth: Version 6.0.14d13, 3 services, 27 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en0
USB Device: USB 3.1 Bus
USB Device: Cable Matters USB-C Video Cable
USB Device: iBridge Bus
USB Device: Touch Bar Backlight
USB Device: Touch Bar Display
USB Device: Apple Internal Keyboard / Trackpad
USB Device: Headset
USB Device: Ambient Light Sensor
USB Device: FaceTime HD Camera (Built-in)
USB Device: Apple T2 Controller
Thunderbolt Bus: MacBook Pro, Apple Inc., 42.1
Thunderbolt Bus: MacBook Pro, Apple Inc., 42.1

From RStudio Desktop Will Not Start on

Having the exact same problem and would appreciate a solution.

1 Like

I had what looks like the same problem, and posted a solution here:

Good luck.

1 Like

It worked! Thank you so much @Lex ! I had installed the previous version with no luck, and didn't think to go back one more, I think, out of frustration for trying all of the other methods. Thanks for posting here. Looking forward to finally being able to dive in! :smiley:

1 Like

That's great to hear @charlottesauce! I'm very glad it was of use.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.